Accounts screen too slow/not responding

in Main Menu -> pressing on Accounts - it takes almost 10 seconds to navigate there,
even when it finally enters to Accounts screen - every touch there takes too long to response

Which database are you using?

im using sdf database

@mayase compact sql is lack of some advanced indexing features so reporting related features might work slow. I think it is time to upgrade to SQL Express database :slight_smile:

It happens only in Accounts screen (in Reports screen its ok),
also in V3.034 it was also ok.

this week im doing lots of upgrading (windows 7, framework 4.5 and also latest V4), so i’ll do also Express and let you know

OK. Let me know your progress. After upgrade we can make finer optimizations since SQL Server supports some nice features for that.

I have had the same thing!
then you have solved the problem or found?

Sounds like a performance issue with SQLCE DB Engine.

The longer you have been running SambaPOS, the more Transactions you will have, and the Accounts Screens are summary information that is presented by reading the Transaction table records and performing aggregates, on demand (whenever you access the screen(s)).

You may be able to alleviate some of the slowness if you set your Account Screen Filters to something other than All, such as WorkPeriod.

that’s not the problem …

More RAM, more RAM ! :smile:

it is not the ram, I have 4 gb :wink:

CPU usage high?
Bad Drivers or Bad Disk
(my touchscreen has a portion of the driver that goes into a runaway condition from time to time, the CPU spikes, and Touch stops responding - a PC restart is the only thing that solves it)

Disk thrashing?
Check the Event Viewer for Disk Errors (not good!).

Accounts has to be generated on demand, and can take a fair bit of CPU power to calculate. But don’t forget about not just the General Account screen, but also any other account screens you have as well for Customers, GC’s, etc.

1 Like

the problem is not on the accounts screen and not even in the report,
the problem occurs when you do the login and logout, it takes 10-15 seconds to enter.
Only in that screen!
ilo problem also with SqlCe40Toolbox

What version are you running?
Did it happen after an upgrade?

before 4.1.37 and I gave him problems,
Then I upgraded to 1.4.38 and the problem remains


  1. Try maintenance functions such as compact, repair, etc.
  2. Be sure a security app does not block access to sdf file for verifications, tests, etc. A tool like procmon.exe might give you an idea.
  3. If possible upgrade to SQL Server. I’ve tested accounting system under SQL Server with ~30 Millions of transactions. Works fine.

i dont believe it got ro do with a mass of data, once i upgraded to v4 from v3 it started working very slow, a day before i was running v3 and it woked perfect, so few more transactions that been made until i upgraded to v4 - i hardly believe caused it.
@emre do you suggest that a database that reached about 1500 transactions is worth upgrading to sql server? For a single standalone sambapos (no terminals)? You mentioned it before but i havent got the time to do it, but maybe something is wrong

@mayase SQL CE is just a 2MB database engine and it does not contain some advanced indexing features. If you experience performance issues you can solve it by upgrading it to free SQL Express edition.

right now my sdf file is 20M
hopefully soon i’ll have the time to do the upgrade and let you know if it solved this issue