Action to restart Messaging server?

Hi there,

I’m wonder if there’s an action to restart messaging server client?

Asking this as

  • Occasionally I put my windows tablet to sleep to save battery during break time, non-peak period etc.

  • Once I turn it back on, Wi-fi reconnected. SambaPOS will work as expected (i.e. browses navigation screen, take order, etc.)

  • But Messaging client will sometime not work. Despite still showing green “Connected” text

  • For example, I need to manually refresh the entity screen tab for Kitchen Display screen to reflect changes

  • Broadcast message received rule also won’t work

  • The above issue can be fixed by manually restarting the windows tablet’s SambaPOS5. I assume the green coloured “connected” Messaging client status does not refresh it’s most current status ?

  • I might be able to ease the issue a bit by having automation to restart Messaging client?

Does this happen every time you sleep the tablet?

When you say kitchen display do you mean on the tablet??? Or just example if displaying that screen on the tablet?

Not always. Something like 10% chance?. Yes, I use this tablet in a kitchen fer kitchen display. It tends to happen when I turn on tablet and sometimes get a limited wifi status with ‘!’ logo for a brief second before wifi status return to normal , but not always though. (I checked and my ip address before and after is still the same)

I’m on my way to try it with my router at home tonight.

That was going to be my thought… hmmm…
ive always used rdp with ipads so not an issue ive faced…

Yup, my another android RDP tablet works fine probably because the messaging server & client is from the very same machine and never really get disconnected.

I just tried using my surface 2 pro as a client and the issue happened on the third tries I think. It could be the partly with router so I’ll try my home router tonight. If nothing else comes up I might just put my cheap china dual-boot windows tablet to android mode and RDP the thing, as ironic as the solution seems to be :joy:

RDP odly enough works from windows :stuck_out_tongue: dont need to dual boot.

Next sugestion would be checking the power settings etc to see if anything odd there but see what happens with your home router.

Update: It happened at home router as well :confused:

These types of commands will stop/start a service but must be run from an elevated Command Prompt (ie. as Administrator):

sc stop SambaPOS-MessagingServer
sc start SambaPOS-MessagingServer

net stop SambaPOS-MessagingServer
net start SambaPOS-MessagingServer

powershell restart-service SambaPOS-MessagingServer

But the Message Server Service is not usually at fault. It is the Client (ie. a terminal where SambaPOS is running) that has the issue. They do sometimes appear to be connected when they are not, and sleep/hibernation seems to do this. Restarting SambaPOS on the Client is currently the only way to re-establish a proper connection to the Messaging Server.

@emre, is there a chance we could have a way to force the Client to re-check it’s connection status and act accordingly to reconnect?