Android (SambaPOS Mobile) – FreeTags Dropped If Have Newline


This is my first post here so please call me out if I need to do things differently.

I have a 3 Terminal system, with currently 6 Android (SambaPOS Moblie) ordering tablets (Lenovo Tab M7) – that was supplied by StoreSeen (installed at the start of this month, I brought the tablets separately), Mark there suggested that I post here so that I can reply directly if I need to clarify anything.

When an order is sent from one of the tablets with a freetag on an item, but the tag includes a newline, the tag just gets dropped.

SambaPOS: v5.3.0
SambaPOS Mobile: v2.0.54

I have been capturing the packets that go to the messaging server; here is an example of it happening (I have tried to strip any secrets & there could be encoding differences as this is pulled from wireshark):

Any time that a new line is entered (allowed by the app) it does this, I have lots of captures if required.

When the ticket prints/re view it on the tablet the order has gone through but the freetag is missing.

I have told the waiting staff about this issue but new lines can still get entered by accident when in a rush trying to close the keyboard or you forget.