Another Issue with Whozz Calling Device

Show screenshots of the settings that you are changing.

Is this at all related to Caller Id? Or is it purely an Entity Search screen problem?

If that last screenshot is what you are trying to say is happening, then we need to look at the Automation (Rules, Actions) that invoke the Search Screen, and programatically remove the dash.

here the first :slight_smile:

And the second

hope this helps…

it seems to be an entity search problem…

yours is working @Hasa? how is your configuration?

I deleted all the existing customers though. So from now forward the format will be correct for them.

hmm ok i will think what i can do…

another question…
if i write something in “Popup Name” nothing is changing only the phone number

how i can delete all customers???

You would use SSMS and SQL statement to delete all customer Entities. But you probably don’t really want to do that.

If your Primary Field is Phone, that is stored in the [Name] column in the [Entities] table in the DB. You can run a SQL UPDATE statement to change the format of the Phone Numbers very easily to include the dash so that it works with the Entity Search.

However, the following is what I would propose as a solution for you in this case, because it does not involve altering the data that you already have.

You can change the way the Caller Id performs the Entity Search to remove the dash, insert the dash, or use a space instead, so that it matches with your current Entity Data storage format. There is a box in the Caller Id settings for Search Format which probably allows you to change the format of the matched number to coincide with the way your Phone Numbers arectored. I don’t know what the syntax is for that box, but you could try putting ########## in there.

hi @emre,
is there another possibility too change this file “\s(\w{3}-\w{3}-\w{4})\s” ?
I did this:
without lines: \s(\w{3}\w{3}\w{4})\s showing another number
with space: \s(\w{3} \w{3} \w{4})\s showing nothing

hi @QMcKay thats not working:
i tried it out

but thanks for help!

No you should not change that. It is a pattern definition that finds the Phone Number data in the Caller Id output. Since the Caller Id contains numbers in the format ###-###-####, you need to keep the Match pattern as-is. What the pattern means is look for:

wordOfLength3 DASH wordOfLength3 DASH wordOfLength4

You might need to find out what the syntax for Search Format field so that you can take a number like 123-456-7890 which is what the Match Pattern finds and strips out of the line, and remove the dashes so it becomes 1234567890. Then it will work in the Entity Search Screen.

The guess of using ########## for Search Format is obviously incorrect. It was just a guess. The syntax is probably like a Regular Expression (ie. the Match Pattern is a RegEx), and you might need to find out what you need to use there.

When someone calls, what does the Popup Show? What is the format of the Number? Does it contain dashes? Or is it just a string of continuous numbers?

When you click the Popup, what does Entity Search input box look like? What is the format of the Search String input box? Does it contain dashes? Or is it just a string of continuous numbers?

This is the pattern that I used. Honestly I dont see how you can possibly have issues setting this up. Set that pattern on there and change the customer entity type to the format ###-###-####. For me the phone is the primary field so I just set it on the screenshot I provided above.


Hope it helps. Sorry iv been crazy busy and haven’t had the time to help you out as much as id like.

Also I just got mine setup on multiple stations using only 1 callerID com device. I did it by using the following software

I had bought the software for another project and used it for this. Worth it if you have alot of stations but obviously not worth it if you only need one more station considering it costs more then an extra calllerID device. I wouldn’t be surprised if you could find another program that does com port to virtual and over Ethernet all for free. You probably just have to dig around.

That is just a easy temporary solution. I know Emre mentioned something about being able to save the number as a global setting then having a read button for the other stations to grab the number with and automatically create the ticket with that customer. I definitely want to work on getting that, I just have some other priorities at the moment.

hi @Hasa
i tried like you described… still not working…
i dont know why :open_mouth:

its like Samba does ignore the lines between…
maybe i need to delete the clients list…

So what is happening exactly? Does the popup come up?

Look at it like this the more you help us understand what is going on the more we can help you.

Please get this program or something similar to record your screen in gif format and upload showing whats going on.

i got it hellejua!

i’ve got it to change the number in my device settings now is shown the number without “dash”
“##########” like this and now its working… but thank you for your help! :slight_smile:


Great :slight_smile:
Stay tuned, soon I will try to get it working on multiple terminals.

yes this would be interested…

i have another issue, it looks like samba is changing my settings of the caller id device…
If i have set my device and i start samba and close again then the settings are changed… :open_mouth:

Thats very weird iv never heard of that issue. hmmm are the other local settings resetting also like the connection string and stuff? Im not sure but I would assume its saved in the local settings file along with everything else.