Another Issue with Whozz Calling Device

i have a similiar issue like in this thread:

But thats not working for me i tried it but no popup. I tested the device with putty and its showing correct the number. And i didnt found an answer in the forum…
This is my Putty Screen:

Thanks for answers!

Try typing new line keyword as termination string.

Hello @Hasa i tried but nothing …

Hallo @emre you can help me please?

Sorry I don’t have that device so I’m not sure what your problem might be… If you have a question I’ll try to answer.

i have this device and its all working:

But my problem is, that isnt working in sambapos there is no popup showing, and i tried your answers in the other thread i explained!
that is my configuration now:

if this helps…

lol @Manuel I don’t understand how that screen shot helps. Can you be more specific about what you’ve tried? Did you tried @Hasa’s suggestion? How did you tried it? Maybe you made a typo while typing the pattern. Can you show it?

Remove trim chars completely, my entity screen name is default so that’s empty too, and please follow directions closely. It will work I just set one up yesterday

I told you to put " new line " as termination string but I don’t see it in your screenshot?

I’m pretty sure I needed the match pattern that is on my other forum too. You don’t have a match pattern on there at all?

Also my baud rate is 9600, why is yours 0? Please go look at my other forum post

Please don’t bother emre with such questions just because you haven’t followed directions closely and want instant help. That will only make things worse, he’s our developer and only called upon for help when it’s a serious program issue that no one else can fix.

Everyone else on here is happy to help soon as we can


ok my fail… :frowning:
i did something wrong, I have always filled only one field.
I tried “new line” OR “\s(\w{3}-\w{3}-\w{4})\s” and now i did this and it worked.

Nevertheless thanks for your help!

1 Like

but i have another question…
how i can change this “\s(\w{3}-\w{3}-\w{4})\s” My number in Samba is this way 433 without line - ?

What I did was I just adjusted samba to have the dash line. Go to entity type customers and change the format to: ###-###-#### so that way you have the line in between. I dont have samba handy right now but it should be fairly simple.

hi @Hasa i did like you described, but its not working
here some screenshots:

when calling its showing this

and when i delete the lines between it searches right…

and if i put a line between no changes:

hi @QMcKay yes i did it as you show me…

Then try changing the match pattern?

From dashes (###-###-####):


to no dashes (##########):


or spaces (### ### ####):

\s(\w{3} \w{3} \w{4})\s

I did it under general settings tab. I just changed the format by adding the - in between to match the ones coming in from callerID

I assume you mean the following… this would only work if the Primary Field is Phone …

Yeah sorry I dont have samba in front of me.

hello @QMcKay
i’ve tried both
\s(\w{3}\w{3}\w{4})\s - showing the restaurant number
\s(\w{3} \w{3} \w{4})\s - no showing anything