ARTECH AD101 Caller Id

I brought a ARTECH AD101 but it fails to work as I do not know how to connect it to Samba. They device works using the demo program it comes with.

Can someone help me set this up please.

What have you tried in samba? Have you added a device? Manage -> Local Settings -> Devices?

I bought a caller ID, just used generic modem device from list, set the com prt and braud rate and worked out the box.

The issue is the com port and braud rate, its connected via usb so I can not find this info.

It might be usb but the drivers for these type of deviced install it as a USB->Serial adapter.
Check in device manager to see what com ports you have listed.

It might not be in the com port section.
Mine shows up in modems section in device manager;

Mine registers as a input device on Port_#0003 no mention of modem.

Got a screen shot of device manager screen?
It shouldnt be an input device.
Have you isntalled the drivers as that grey box thing is usually on non-installed/unrecognized devices.

The thing works on the demo program that came with the device.

Channel 1 is the called Id device when I call the line it shows its id.

But need to incomporate this into samba.

Got a screenshot of device manager screen?

The specs on website mention

-HID USB data transmission without USB driver

I would say this suggests one of the following;

  1. You haven’t installed the drivers properly and is ‘defaulting’ to HID device
  2. It might not be compatible if HID is the only option/driver.