Automation Key Pad

@emre I need your help on this one.

In the retail setup im creating I want to have a keypad on the screen created by the custom product buttons so that im not using the ‘built in’ keypad from the category settings as this fills the entire width of the area and cant be customised. It also then creates a scroll bar as the pos buttons dont fit on the screen due to the size of the built in keypad

What i have done is created auto commands for each keypad button, the issue I have is that when I press a button it correctly appears in the text bar, BUT when I Press the next number it overrides the first number entered instead of adding it as the next number. Is there a way you could add a setting or enable a way that this ‘override’ doesnt happen and that the auto commands ive created will act like the built in keypad?

Some screen shots of the issue

  1. Built in keypad at 50% of screen

Takes up a lot of space and creates a scroll area above hiding pos buttons

  1. Built in keypad at 25% of screen

Shrinks keypad to a not very user friendly size and still creates scroll bars above

  1. My Proposed Solution, automation command number pad

Fits in with the pos theme being created, buttons can be customised in colour, font, font size, images etc etc (and looks really good IMO)

But here comes the issue
Press number 1 and as you can see below the number 1 appears in the text bar at the bottom of the screen, this is Perfect!

BUT, if i now press the next number, for example if i was using it to change the price of an item to 1.95 when i press the decimal point button this overrides the 1 to just show the decimal point

and the same when i press 9, then 5

What i want it to do is keep all the numbers entered in the text field so that we can use that value as the {NUMBERPAD} or [:NumberpadValue] what ever the correct format is, inside actions like we do for the built in number pad. So it should display the following when pressing 1.95, then i could press for example the price change button and it would change the price to be 1.95

Is there a way you can make this possible, or a way to not reset the text field every time a new number (automantion command) is pressed?

1 Like

Remember you can define a custom Keyboard if you edit Menu Category.

yea but then it creates 2 separate areas, custom product buttons above and custom keyboard below so the input field would sit in the middle of the screen, in between these two areas when entering numbers. its also much easier and simpler using custom product buttons to create the buttons, and move them around than using custom keyboard. I also like the fact there is no divide in the screen with just using the one area of custom product buttons and that it is one area.

If i remember right when i tried this before as two separate areas i couldnt get the size of the button in both areas to match so it looked off, its also a pain when editing or moving buttons round having to edit custom product and then custom keyboard

The custom product buttons work perfect, its brilliant and so easy to customise it would be great if we could sort the automation keypad to work as it would all fit together perfectly, call me a perfectionist but i really like the look of it and easy it is to customise without using custom keyboard :slight_smile:

Have you tried making one button and using custom keyboard template for button? I mean it would scale wouldnt it?

@RickH am not sure how you are putting numbers in to automation command but as a ‘temp’ solution could you not make the automation pull the existing numberpad value and add the new number then update whole thing, ie;

1 = 1
. = {NUMBERPAD} . = 1.
9 = {NUMBERPAD} 9 = 1.9
5 = {NUMBERPAD} 5 = 1.95

1 Like

hi @Jesse, the problem with custom keyboard is that it fills the screen left to right, i just want to literally use the spce the number buttons occupy and have other buttons around them. Having it all as custom product buttons works really well, just one place to update/add/remove buttons and edit them. i find it much simpler than custom keyboard and is so much easier to edit

@RickH did you have any luck with my idea?
Had a thought in that it could be even simpler with one action for setting numberpad value on the presumption the custom buttons have command and command value fields.
Automation command rule for command equals ‘CustomKeyboardNumberpad’
Action of Set NumberPad Value
Value = {:NUMBERPAD}[:CommandValue]

The custom buttons being command name of ‘CustomKeyboardNumberpad’ and value of whatever…

Not sure on what first number will do though, if numberpad is empty if it returns 0 or blank, hopefully blank…

Hi @JTRTech sorry i was writing this post at 4 or 5 this morning after feeding the waking baby and i was knackered lol, i forgot to post my setup. This is how i have it setup at the moment where pressing the number button (custom product button with automation command assigned) inputs the correct number but each one overrides the previous

Automation Commands - 1 for each button

Action - Set NumberPad Value

The Rule

Custom Product Button Settings

@JTRTech i wasnt sure what you meant, any chance you could do me a quick example and ill try it?

In you Keypad Button rule…

In the Net Numberpad Value action
Try putting {:NUMBERPAD}[:CommandValue]

In theory this should take the current numberpad value as a prefix to the command value.

Not sure is reading the numberpad in an update numberpad action will work.

If not I would try giving all numberpad custom buttons a command value which is the same, trigger the rule with the command name but set {:NUMBERPAD}1, {:NUMBERPAD}2, {:NUMBERPAD}3, {:NUMBERPAD}4, etc as the command values inn the custom button command values column.

does exactly the same thing and overrides previous number :frowning:

this is what i changed

Ok, thought it might be an issue;

Try this;

Doesnt work either… hmmmmm

Nope doesnt work either :frowning:

Very odd…

This works to update program setting;

However this doesnt…

Program settings…

Triggering the same rule from an automation command button works as expected;

Im guessing that for some reason the {:NUMBERPAD} tag doesn’t work in an automation command rule if triggered from a custom button.

But this doesnt work;

Think this is something @emre might need to look at.
As far as I can tell a custom button triggered automation command rule cannot pick up {:NUMBERPAD}.
If in the rule its giving blank and as Value in custom button menu settings it give the string {:NUMBERPAD} as the value so neither approach works.

thanks for trying it out, hopefully @emre can find or add the solution :slight_smile:

Just tried a double automation command loop

Custom Button (Command Name=CustomKeyboard, Value = 1) -->
Rule 1 (Command Name = CustomKeyboard) --> Ex Automation Command Action (Command Name=CustomKeyboard2, Value = [:CommandValue])
Rule 2 (Command Name = CustomKeyboard2) --> Set Numberpad (Value={:NUMBERPAD}[:CommandValue])

Still doesnt work so something defiantly not liking {:NUMBERPAD} when triggered via custom button on menu.
Its not just the initial rule but even the knock on rule triggered by an exacute automation command.

As a side note the double command still works if 1st rule is set to go from the Test button with value 1 as before.

:frowning: hopefully we can get this working as it looks pretty good on the setup im building :slight_smile:

1 Like

I’ve explained it in this tutorial. You can read it with [:Numberpad] by 5.1.57