Avery FX120 scales not receiving data via putty


Can anyone confirm if Avery FX120 scales work with sambapos

I have them connected via COM2 serial. Putty is not receiving data.

Using W command.

Do I need to press a button from the scales to send data. Tried everything and searched google etc with no luck

Thanks all

Putty is not Sambapos. But if putty won’t work then Sambapos won’t either. You should first get it to work in putty.


Thank you for the reply. I get that putty is nothing to do with sambapos.

What I’m trying to establish is does the Avery FX120 model compatible with samabpos or do I need to purchase a different type of scales.

I’m trying to get putty to read the scales, the online manual for FX120 model has no instructions on how to send data readings from the scale to windows. I have put open using com2 port (plus i have tried all com ports) there is no reading.

Windows device manager shows no issues with ports. Scale are weighing products with a reading on scale display.

The FX120 has serial ports for output and on google it says compatible with pos software.

Unless I can find how to get putty to acknowledge they are connected and reading data, I need to purchase a different model of scales.

I’m stuck in a catch 22 because I don’t know what I’m missing to get putty to read scales OR what other scales will work with sambapos. Brand and specific model.

I need help in what direction to go with Thanks,

Sambapos is built so it can communicate with any scale that can show data in putty. But a common scale used is Cas ER jr