Call Display problem with DDN as NUMB

Hello
OS= windows8.1 /64bits
Sambapos 4182
Modem = Hiro USB data/fax Modem
My phone line company is Bell Canada and it returns in putty as shown DDN instead of NMBR


Therefore, I have edit the modem installation configuration file .inf
tutoral as this https://www.beiley.com/acallerid/fixdriver.html
And windows registry file
https://www.beiley.com/acallerid/fixdriver_registry.html
And it is working with other programs now
I have tested it with simplecallerid, callerid
but sambapos has no response at all

Do i need to do a clean reinstall?

can you try follwoing:


Thank you for your time to reply.
I have tried both for many times, however it has never shown any pop up.
i have fresh reinstalled, but nothing is change.

As my caller id is DDN not NMBR does it matter?
I am just curious because if the caller id is turn on and it could not find numbers it should still have pop up right?
is there any registry i can look into?

Because your are using DDN issue may lie there.

What happens if replace NMBR to *DDN.=?[^0-9]+([0-9-\s]+) for Match Pattern setting.

DDN.*=?[^0-9]+([0-9-\s]+)
DDN.=?[^0-9]+([0-9|-|/s]+)
DDN.=?[^0-9]+([0-9]+)

If above does not work then need emre to comment.

I have tried all of them, it doesn’t work for me.
thanks again