Caller ID popup slow to show or not show at all


#21

I can show you but i cant upload video


#22

Yes screen is freezing for 10-15 second


#23

Do you have chance to test how “Display Popup” action works? Does it also freeze?

Edit: I’m asking because both test link and display popup actions works fine for me.


#24

“Display Popup” action works fine


#25

OK I Reviewed related changes but there is no change that may lead to that.

Generic modem displays popup under a separate thread. As whole screen freezes that may mean a windows os related resource sharing issue. I disabled thread creation and committed it. Yesterday @VehbiEmiroglu will update beta release. After update I’ll be glad if you can let me know if it makes a difference or not.


#26

ok thank you very much


#27

I am confused by yesterday did you invent time travel? HAHA sorry I had to.


#28

LoL it is not yesterday …


#29

No its tomorrow … OK now im confused even more :stuck_out_tongue:


#30

Sorry I’m bored at the restaurant tonight its slow.


#31

I generally visit https://news.ycombinator.com/news when I’m bored :slight_smile:


#32

Sorry for late update. Yes I am using a custom detail format, same as has always done. (you probably didn’t notice as I replicated the default format for when customer entity doesn’t exist)

{DATE} {TIME}
{ENTITY NAME} Calling...
{ENTITY DATA:First Name} {ENTITY DATA:Last Name}
{ENTITY DATA:House No.} {ENTITY DATA:Street}
{ENTITY DATA:Town} {ENTITY DATA:PostCode}

Here is the settings I used that have always worked:

image

(Initialisation string is to force the modem to UK mode and turn on Caller ID function)

This customer doesn’t have internet installed yet so I haven’t been able to test. I am likely going there later today, they have 2 systems and one of the modems wasn’t working properly in Putty so I am replacing it.

There is another situation, I haven’t mentioned because it worked in Putty and since it does there, it should work in SambaPOS…

I usually use Zoom 3095 modems, have been for the last 2 years. In the UK they are one of the few brands that work properly with BT’s (our main phone provider) Caller ID standard. The last 5 modems I received from my supplier came in new packaging and have model Zoom 3095A, they look slightly different (rounded body). The new packaging has 2018 date on it, compared to the previous one of 2016. However looking more closely, the new packaging has only English and Spanish on it, whereas the previous packaging had a whole load of European languages. The supplier also increased the price by 50%, so I think this “A” version is actually meant for the USA market and not the UK and may not have proper support for BT Caller ID (however it came with a correct UK phone cable).

I did not report this issue sooner as I was certain it was an issue with the new version of the modem and was struggling to find the old model again, thinking I’d have to start supplying the only other one I know that works - a more expensive USRobotics model. However I managed to find the previous model being sold again from another supplier and have 2 delivered yesterday which I am going to replace at the customer site likely today.

Modem I usually got:

The one that came recently in last 5 I purchased, can’t find a box image online but you can see the body is rounded, this is 3095A version:

Even though I am keen to blame it on the modem, when I tested at the client site, the 3095A model worked perfectly in Putty as shown in the video, but SambaPOS was still displaying late or not at all.


#33

Side note… if you ever want a realiable device the industry leaders for these devices are http://www.callerid.com/


#34

Yeah I know but they are also 3-4x the price of a modem that provides caller ID, and frankly they do the same thing, in SambaPOS we don’t need all the extra programming support these devices offer. The problem we are having with the caller ID right now I wouldn’t be surprised if it also causes problem with those devices too.


#35

@emre
Last update from today did not solve the problem.
Still when incoming call it takes 5-10 seconds untill popup is shown.

EDIT: i have some rolls to fire load entity when incoming call and when i disable the load entity action the popup is shown admittedly with no problem.
On this Version of samba it takes time to load antity and this freezing the screen untill the entity is loaded.
Was working fine before upgrading to 5.2.19.
Before I was using old Version from a year ago.
Thanks.


#36

@emre
Also when I put a phone number on the search field it takes a 5-10 seconds to load the entity from database.


#37

This is not the same issue I have. For me everything else works fine, just the delay in Caller ID popup.
It sounds like the issue you have is could be related to the database - is SambaPOS running smoothly otherwise?


#38

@pizzaeilat4 go to program settings then maintenance try running the safely autosize task. Backup first of course. That may fix your search issue.


#39

Thanks @kendash
I tried but it didn’t solve the problem.


#40

Can you PM me database backup?