Caller popup shows date instead of phone number (SOLVED)

I have a very strange thing happening today, my caller ID popup doesn’t show the phone number but instead is shows the date without the first “0”.
Through putty I get the correct information. Also the property editor is filled wiht the correct info. My device is the one from Ebay with the conextant driver

Marza this is really strange. Does it happen random or always displays date?

Only once it gave the correct state,with phone number name and address. Now it happens every time with the date. I will give it a try on another terminal. Indeed very strange :frowning:

If you can catch a corrupted response with putty we may identify it better.

I have tried the same moden on a different terminal usin Win7 prof. Guess what it worked but one thing that’s strange is the order of the “DATE” “TIME” “NMBR”. In this setting below it’s working but in when I am in the restaurant using Win8 home the order in Putty is “NMBR” “DATE” “TIME” very confusing!

That change in the order is not important since we locate the NMBR prefixed line.

Can you check Port settings and compare it with the working one?

The settings are the same and I have also changed the bits per second from the lowest to the highest. Cause I am not in the restaurant now I will check and compare every single setting later today, I give you the result. Thanks till now, good night!

@emre I was out for a couple of days. I’ve checked the settings and they are completely the same. With my laptop with SambaPOS installed I checked the CID at home and it’s working perfect. At my restaurant I can choose between 2 caller ID Methods.

  • ETSI FSK (Putty respond “Date” “Time” “NMBR”
  • FSK+DTMF (Putty respond ring ring ring)
    I have no idea where to start, still getting date as phone in the popup

@Marza it is a little hard to define such problem, there might be an issue with device, the port it connected to, the line cable or the splitter you’re using. Some China made models might work unstable too. What we do from SambaPOS side is just locating the line starting with NMBR and extracting number from it. Since it creates popup the result should contain NMBR line but I’m not sure how it can extract date from that result. If you can catch a corrupted result with putty we may define the issue better.

There is no corrupted result with Putty, the notification in putty is correct. The same modem is working correct on a different phone line. I think I will order a CTI Comet caller Id hope that makes sense. Thanks @emre !!

I’m not sure if it relates with the issue or not but if there is ADSL on same line using a splitter may help.

It is a ADSL line, I will buy a ADSL splitter tomorrow ad give it a try. The first time I hooked it to computer and the telephone ring, it worked once with the correct data. But thanks again and I will report the result. Good night @emre

i have this problem generic modem error access the port com3 is denied any body help me

You can not use putty and sambaPOS at the same time, because they use the same port there will be a conflict. Quit putty and start sambaPOS again.

thanks now its working but i see only phone number

First you have to assign data such as Street Zipcode or City to the phone number. When the information is stored caller id will identify the customer by the phone number.
If you would like to see customer details in the popup you will have to put {ENTITY NAME} {ENTITY DATA:X} in Generic modem > Settings >Detail format

@emre, Gave it a try with the Adsl modem but still negative result, When I connect the splitter, the phone line is dead only modem (data) works fine. This is annoying me cause putty and my telephones give the caller ID the way it should.

To reset it to default settings did you tried removing caller id device and adding it again?

Several times I removed caller Id in SambaPOS and add it again, I removed the driver in windows en reinstalled it again. :frowning:

Hi @emre, the problem is solved by using,


1 Like