Cannot enable 'Training mode' in V5


Why is my screen shows it but I can’t activate it?


Can you show a screenshot of how you cannot activate it?


It creates a duplicate database? Are you in TXT mode? Not sure if works in CE.
Double click samba logo in tap left when logged in as admin and look at the title bar,the final letters show the DB version.


Training Mode is only available on SQL LocalDB or SQL Express databases. So it needs to show SQ in the title bar.

If this is the case and the “Enable Training Mode” button is greyed out, it is likely you are using SQL LocalDB and you have a blank connection string (this is the default setting also!)

I found this issue before, you can read more below, but basically you just need to update your connection string so it is not blank. So if you DO have a blank connection string, Edit Connection and change the “Data source” to (LocalDb)\MSSQLLocalDB. Save and click Apply. After you login again, you should find training mode is available. If not, try restarting SambaPOS.


Did what Mark said. My version says SQ. I was able to ENABLE TRAINING MODE but then it doesn’t want to DISABLE IT now… here is the screenshot:

I need help please…


another screenshot;


and one last screenshot:


Your user permissions for the windows account do not have the permission it needs to delete the database


However LocalDB only works under current Windows user account…


He may need to start sambapos as administrator


Not something I have tried, but according to my experience with LocalDB, if you do that it will not find the database because they are stored in the user profile folder by default and it runs under the current user.

I have used LocalDB with Training Mode a number of times and never had this issue.