Cannot set-up Caller ID

Hello to SambaPOS community users.

I would greatly appreciate if someone could help me set-up Caller ID feature on SambaPOS 4.

I have compatible modem, (CTI METEOR) I can see calling number from putty, but in POS there is no any kind of widget or pop-up screen coming up.

I have followed this guide step by step:

and Caller id popup

Took advices from here

And have read all related topics to Caller ID feature.

But unfortunately no any progress by now for few days.

Would greatly appreciate any information regarding this matter.

Thank you everyone in advance

tri this,

I should type this

In the putty, right?

emre said:
try typing NMBR.*=?[^0-9]+([0-9-\s]+) to Match Pattern setting of your modem
If it does not work try one of these

In the Putty terminal, correct?

Well, I don’t get any response there, even commands like ^E does not bring back echo

not In the Putty terminal
in the Match Pattern setting of your modem in sambapos

Have tried both of patterns, still no luck.

Maybe some of the other settings are incorrect?

Baud rate is correct for 100%, this I got from the documentation of my Caller ID developer, and only with this baud rate i can get some output in puTTy. If I put 9600 I just see random chars every single time.

Maybe something is missing in my entities, or somewhere else?

Have tried to do that for clean installation for sample data, still pop up does not appear.

Have tried to restart Samba after adding pattern as well.

if not working then you will have to wait for @emre to Respond.
There may be other NMBR code that matches your modem

@r00t please connect your modem to PUTTY and post your PUTTY screenshot here so we can understand how your modem responds.

Hello @emre

Here is the response from PuTTY

The modem does not pick-up time & date, but this is not critical. In my other POS which I have used before it didn’t pick-it up as well, however it was successfully picking up the customer phone number.

Which line is the phone number? Second one?

Yes, second one. The one starting with 075***

Can you try setting [^0-9]*?([0-9]+)\^OFF-LINE as match pattern?

Tested, nothing appears…

Emmm, maybe I’m stupid (I guess this is the case), but does this pop-up window have to come up at any occasion when my modem is receiving the call?

Do I need to create any Entities? or Entity Screens? Maybe some Entity Types?

Currently I have no any Entities set-up, and only one Entity Screen which is main, and no any more are needed anyway.

Thank you

You only need Customers entity type and device configuration to see phone number popup.

Close Putty while testing.
Try restarting SambaPOS.


No need any automated actions or rules or triggers?

Tested once again after another restart of POS and with closed PuTTY, no luck.

I’ve assumed the blank part in front of numbers is space chars but it can be something different. Can you try these in order and let me know your result?

  • \n[^0-9]*?([0-9]+)
  • [^0-9]*?([0-9]+)
  • ([0-9]+)

Hello, my apologize for the late reply. I’m currently on the holidays and I haven’t got access to the POS at the moment. As soon as I will be back I will test this solution and will write an relative reply. Thank you for the help. Best of luck

Hello everyone,
Came back from the holidays and keep trying to make my caller-id get working. Still no luck.

@emre, I have tried your match patterns, however it still bringing me a headache as there is nothing appearing.

Now, what I have tried more, and what happened:

  1. I have changed in the device manager, in the COM port settings Baud rate to 1200, same as in the Samba.
  2. After adding one more caller ID device (CTI Comet USB Caller ID) and adding to it match pattern [^0-9]*?([0-9]+), I got two pop-ups appeared, which was saying “call 1” & “call 2”, after pressing on one of them, it opened customer screen.
    Second call didn’t bring anymore any pop-ups until now. Tried to delete and adding devices again, but couldn’t see the pop-ups any more no matter what I try.
    However, now I’m getting different pop-ups.
  3. Generic Modem Error - Access to the port “COM1” is denied.
  4. Information - To be able to display Caller-ID you should install hardware drivers.

Well, if the first error is easy to get rid off just by restarting PC, then second one is not clear for me at all. Caller ID I’m using is CTI METEOR PLUS Single line Caller ID device which is powered by COM port, and there is no any drivers for it. Not on the developer website and never had to use them before.
Also, if I just start different POS I’m currently using, it picks up this modem straight away without any drivers or so.

Would greatly appreciate any help if possible.

Thank you very much


Some info from developer:

Maybe will be useful for someone, specially part 5.0