CAS ER Scale (no communication between POS hardware)

Hello guys,

I bought CAS ER plus scale for Sambapos 4, and original serial cable for communication with POS system but no any effect. Begin yesterday i am busy on it i have tried all of combination with Com port setting but no any info i got from scale.

I try to contact with scale with putty but no action ! I use Windows 7 pos ready and i have 2 com port on my hardware (EBN) but still didnt contacted.

Please i need a information about that maybe any special way to contact with scale ?

I need your helps.



If you cant get anything with putty you need to work there, samba pos will not receive anything if the device isnt configured to work with the computer/windows in the first place.

1 Like

My question is that exactly ; how can i configure it for windows ?

On my device i have a com3 and 4 and scale connected with Com3 port

Com3 port configuration like that ;

Bits per second :9600
Data bits : 8
Parity : None
stop bits : 1
Flow control : none

This is standart windows com port configuration. Can anyone help me for this case ?

Thanks a lot

You should see something like this on Putty screen when you scale something.

There is no special configuration on windows. It should just communicate fine through serial port. Maybe you should check port drivers or serial cable. After seeing proper results with putty you can configure SambaPOS to use your scale.

Here you can find more information for putty configuration.

Dear Emre

Firstly i need to fix connection problem between Pc and scale. When i try to connect with putty just connection error black screen, no any action by my.

Does it have a test software? We tested it with CAS ER Jr model so I don’t know if you need to do something specific for plus model. Maybe contacting CAS support will be a better idea.

@mehmet anyone you know uses CAS ER Plus model?

Dear Emre,

No any test software for this scale and i try to test with test software PDII but i dont understand lot of models on list but not CAS ER i ll call tomorrow CAS for information. I am tired because of this scale i become crazy, original cable also i have tried with null modem cable but no any action. Com port is ok i have tested with client display and i can communicate with client display normaly.

How can i test it have any other way to test it ?


Nobady can help me ? :slight_smile:

You issue is between scale and windows not samba.
You’ll probably find no one has the same scale and many don’t use a scale at all.
As the issue is between windows and scale (not working through putty) it in theory is not something Samba forum can necercerally help with, not samba specific issues can often be advised by members who have experience with that issue but given there will be a limited amount of members with experience with scales the amount of support with this non samba issue will be limited.
Emre has shown what you would expect to see in putty, if putty isn’t receiving samba wont be.
Have you spoken to the scale manufacturer yet?

Dear JTRTech,

i know that this issue is not Samba but i am here busy with samba and i ll implement this scale to Samba. Thats mean not you MUST help me i try to find solution here i have read and watch video here in forum and they are already implemented this CAS ER. Why i am here understand ?

Maybe some one here have a experience with this type scale. My Pc’s com port is ok i have tested but when i try to contact with Putty no any action i can understand that this issue between Pc and scale communication problem but i try to understand Why and where is problem !

Today i have called USA CAS head office and try to contact with technical department but they said you need to contact with your local dealers. Local dealers have a no idea about this issue and i am still waiting call from dealer they ll check this issue when find any info they ll call back this mean i cant get any info from there this case i try to find solution here also another forums.

Thanks you for all

Are you sure its just not something silly like faulty scale?

I am thinking about that because when i buy this scale was not sealed box (was open) that case i called today again that company and they ask is any communication problem between Pc and scale i am thinking about that maybe this scale was not ok they know because when i buy RS232 cable they asked what you ll do this cable you cant contact with your pc if you like we can sell complete pos system to you etc. etc…

I ll call tomorrow again or i ll take scale and go to there i want to see on location, because they have showroom and lot of working scale there i want to test this scale there :slight_smile:
this is best option i think than i become sure if worked must be work by my also…

Right ?

Serial communication is pretty basic and even if it were to use some form of proprietary language/encryption I would still expect putty to receive something but maybe jumbled noncence if it was something non-standard.

Had a quick google and there was a page suggesting a raw test could be done with a volt meter changing for voltage variance across a pair of pins, in theory this would be an ultimate way to test if issue with device.

Have you tried different cable also maybe?

I have tested also with null modem cable but i dont know is that capable or not but tested anyway no any action also

Hi Guys,

Scale is ok just communication problem between PC and scale, Scale working with another POS software i think not compatible with Samba. I bought this scale because of Samba Scale integration video but i dont know how can i integrate it now !

They saying we cant get back this scale, i found all of details about Com ports, How can i work with this scale on Samba is it possible with some rs232 cable modification or not ?

Please check attached file for protocol details ?

Thanks for all for efforts and time

For idea AP_ER Interface (355.9 KB)

But if it’s not working with putty it seems very locked down!!!
Think they are just blowing it on POS…
COM is very basic/standardised in general and if not feeding into putty… well… Not sure what to say.
Does it have some kind of special firmware which makes it specific to one POS)

Hello Everybody,

I ve contacted with dealer for change this scale with CAS PDII serie but they said CAS ER plus and PDII using same protocols if not worked on CAS ER PLUS PDII also not…

But today i have received important information about Types. I can select on scale protocol Types

I have read this on another POs systems forum please take a look :

Now i need a information about protocols SambaPOS support one of them if Samba Pos worked on CAS ER Jr serie scales.

And here i found CAs ER plus Service manuel :

on page 36 RS232 communication informations.

Maybe now you can resolve this issue ?

Thanks a lot

@lekker I read the post you’ve referenced. See that part…

I tested the CAS ER plus output on Hyperterminal and Netbeans. In both cases, same output comes up:
Example => S 0.175kg
S is the character that comes up prior to the weight in kgs.
After S there is double space and the the weight and kg.
Total of 10 characters.

He says with Hyperterminal (something like putty) he can receive Example => S 0.175kg output but POS software he’s using can’t read it.

Your problem is you can’t receive an output… First you should be able to read values from scale. After reading it we can discuss what can be done on SambaPOS side.


Emre Abi,

Did you changed any Type on scale ? I think all types have another protocol or i am not sure but this CAS ER Plus have 12 Types and they said please test it type 5

If i get any info from scale i can fix the rest but my big problem now connection. And i have called again and spoke with distributor they ll change with PDII model but i want to know PDII working on Sambapos or not ?

If you say you can take this models i can take it for me easy :slight_smile:


As emre said the post you linked to was receiving from the scale in to hyperterminal (which is similar to putty).
Your issue is that part, you not receiving anything, no one can help with samba side if nothing is getting to windows/pc in the first place.
HOWEVER, the second post suggests the scale does not support continuous weight… does that mean you have to press enter or something for the weight to be transferred/transmitted?

1 Like