[New 4.1.4] Scale Integration

You can connect scales to SambaPOS by configuring a scale from Management > Local Settings > Devices

My Scale is CAS ER model. To configure port click Settings and choose the port your device is connected to.

When a scale connected, scaling automatically updates Number Pad value. So when you add a product quantity value becomes scaled value.

Custom Scale

If your scale does not listed here you can try integrating it by using “Custom Scale” option. To be able to make this configuration you need to know how regular expressions works.

Connect to COM Port to monitor what information scale sends. You can use a terminal application like putty to monitor that.

Select Serial Option and type port name. Clicking Open should display terminal window.

Our test scale is CAS ER model. This Scale continuously sends scale value as ** S x.xxxkg** format. We’ll use a regular expression to extract x.xxx value.

When you select Custom Scale option scale settings contains additional field called Match Pattern. Our Regular Expression to extract weight value is [^\d]+([0-9]+[.,]+[0-9]+) so I typed it to Match Pattern field.

If you are familiar with RegEx please notice we are using first group value to find weight.

Scale Demo

1 Like

I moved 3 posts to a new topic: Custom Scale Question

Hi Emre, I’m new here and hope i posted in the correct category. I’ve successfully connected my CAS SW but it only display 0.001 in sambapos when i’ve placed an item weighing 1.28kg on the scale.
I tried weighing 2.5kg but only display as 0.002 and so on. It doesn’t seem to capture anything after the decimal.
Below is the output from hyperterminal

I’ve tried custom scale and it still give me the same results. Tried ([0-9]+[.,]+[0-9]+) and a few combination still the same What is the match pattern should i use in this case?
Please help…thank you

Did you tried [^\d]+([0-9]+[.,]+[0-9]+)? What is your windows regional decimal separator?

Yes, i’ve tried using [^\d]+([0-9]+[.,]+[0-9]+) and it’s the same result. My windows regional decimal seperator is as the picture. I’ve just tried changing to No. of digits after decimal to 3 and still the same result.

Hi, Emre. Please can you help me on this issue.

Which model of CAS SW are you using? I’ll ask my supplier for a test machine.

I’m using CAS SW-1 (5). Maximum weight is 5kg

Hi Emre,
Did you manage to get a similar unit for testing?
Thank you

I’ve contacted to supplier to request a test device but as we need a specific model that may take a while.

Hi Emre,
Alright, i’ll wait for your good news. thanks

Hi Emre,
Did you manage to get the test device? I’m running late to implement this solution. Hope you can help.

did anyone get the CAS PD II working?

Please keep your questions to one post, asking the same questions twice will not get you any more help and just makes it harder for people to reply and help you as your answers are across different posts.

Its also harder for other people with the same problems to follow the links and advice being given as it isnt in one place