Cash drawer not popping

Hi guys for some reason I cannot seem to get my Cash Drawer to pop open with SambaPOS. TBH i cant seem to get it to kick open even with Printer preferences.

Anyone able to spare some time and help me out?

First rule out physical fault.
If printer utility will not open drawer that is sounding like the case…
Check its plugged in the correct port on printer (its a 6 pin port that looks like network which is 8 pin rj45) if its a multi function printer with network port and your using say USB make sure its not plugged in to network port (happens allot with some of my clients) likewise that it is plugged into the drawer port on printer and not the ethernet port on the till machine - again have had several clients to this…
Test with alternate printer - ideally one you know kicks a drawer ok.
Test different drawer - ideally one you know is working on that printer.
If you cant get it open using printer utility then samba is not going to have much of a chance.

1 Like

The printer is a Epson TM-T88 ii, I have also tested it with a aures TRP-100 (which i couldnt work out if it was that or the Drawer)

The current setup is Cash Drawer via RJ11 into Epson printer, Serial output into Com1 on the POS.

If its epson there should be a utility also with a kick drawer command button…
It might be incompatable drawer posibly, I strugled with one type of drawer and came to the conclusion there are two twpes on pinouts used (think its EPSON style with is most command and Star which is less common but never bothered testing much deaper as they were cheap drawers.)

The cash drawer doesnt have any markings on it to say what make or model it is :frowning: so dunno where to start here … this is all new to me

Drawers are very basic.
If it’s an epos printer find the utility with open/kick drawer button.
If that doesn’t work samba has no chance.

Sorry to be a pain but I’m not too sure what kinda utility that would be. Very very new to all this, it’s a Epson tm-t88iii printer

The epson printer driver utility

Ive installed many t88 ii printers and they all can kick the draw open. Though ive always done the following whenever ive had to trouble shoot cash draw kick open issues.

  1. Check to ensure printer can actually print first via test print in windows then can print in sambapos. If it test print properly in windows but not samba then we first need to configure to get printing in sambapos to work to move on next step.

  2. If test print works in windows but not sambapos then we ensure the correct printer and its configuration is selected. T88 works with default sambapos settings so just ensure ticket printer is configured to the t88 and the mappings are configured properly then test printing.

Since cash draw is connected to printer, if printer doesnt print at all then usuallu it wont kick the draw open either.

  1. If printing works in sambapos, then i usually use the code in a printer template, assign it to t88 printer, and create a auto command for cash draw open. You can find the tutorial for creating an open cash draw button in forum.

  2. Once you have that button setup, next is to test if the button will kick the cash draw. If the cash draw rules and actions are configured properly and printing is working, it should kick open the cash draw and a click of the cash draw button.

If it is configured properly but still not opening, next i usually check the cash draw cable that is attached to the printer to ensure its securely set in place. If your cash draw had a rj11 port also then it means we can even test differenr rj11 cables to see whether cable is faulty. If the cash draw doesn’t have the port but instead its non removable then you may have to test the cash draw with another printer or test another cash draw with that t88 printer and see what happens.

If your current cash draw works on a different printer then most likely its the port of the current printer being faulty or the it just doesnt support the function (unlikely but possible)

If a different cash draw works with the current t88 printer then fault is isolated to the cash draw being fault. The fault then could either have something to do with the cable connection at the tip which goes into the printer or the port of cash draw is faulty if removable, or connector inside cash draw is faulty somehow.

1 Like

Hi guys, thanks for your replies. I just cannot seem to get this working at all :frowning: I downloaded a few tools now and just cannot seem to get it working.

I got me some tools too. Tried them, but still no luck. For some reason I can’t get them to work. They just sit there on the floor and do nothing.

More information: A small girly hammer, and a hacksaw.

@Colin_Lundy, did you try the Epson Utility? If you did, and the drawer still does not pop, then there is a physical problem with the Printer, the Cable, or the Drawer, or an incompatibility between them.