Changing Database, which is the best route?

I was told that I need to change the database I use. It is laggy, and now I’m on a super duper fast till system that i built I can literally do anything I want without having to worry about running out of memory anymore.

Whats the best database to run with samba, and how do I go about changing to it?



You should be running SQL Server Express 2014 64-bit for the best results.

What DB are you currently using?

no idea, how do I check?

Do you remember last week you looked at my database and said that it was slow and needed updating?

Ok, if I said that, it is because you are running SQL Compact Edition (CE), and yes, it is slow. You can check this by double-clicking the SambaPOS title in the top-left. This will reveal the Title bar, and the last 2 characters indicate the Type of DB you are running. If it says CE, you should definitely upgrade your engine.

You need to download and install SQL Express 2014:

I recommend the full package for x64: ExpressAdv 64BIT\SQLEXPRADV_x64_ENU.exe

Follow these instructions to install and configure SQL Express:

Once you have it installed and configured, you need to convert from CE to SQL:

sir you are a diamond!

I started downloading sql server but not the adv, so i cancelled and started again.

Thanks for your help, can’t stress enough. After a busy and stressful weekend with staff queueing to use the till I decided enough was enough and I needed to upgrade it.

Good job i bought all of the database tools!! :smile:


Ok so far, I have samba4 connected to the database that I created but its showing the sample data and not what I transferred over using the script.

Im presuming I’ve done something wrong?

If I look at my database using the server manager i can see tat it is the correct database and it shows my products, so I presume its just as simple as loading my database onto the one i created? I can’t see how to do that.


Bizarrely, I imported that database and replaced all tables and its still showing sample data? ill have to cancel it for a bit now as I have to keep trading, but I’m almost there anyway.



Back on it now, really not having a good time trying to do this.

Im having trouble connecting to the database apparently. Its window authentication but its not accepting. I also added a new user to the database . “samba” and “sambapos” as the pw.

The connection string is:

Data Source=localhost\SAMBAPOS; User Id=samba; Password=sambapos; Database=SambaPOS4;

any idea?

Update, I changed the string to read just:

Data Source=SHAKES-PC\SAMBAPOS; Database=SambaPOS4;

It now loads but only shows sample data. Im wondering if I have a problem within my database?

If it only shows sample data, that is because the DB only contains sample data (from a new installation).

Now restore your DB from backup to overwrite the sample one.
Then re-install SambaPOS, and do not select “Sample Data” in the setup dialog.
Don’t select anything in the setup dialog in fact.

when I use the database tool it shows this: not sure if its a factor?

It only creates 3 files names SambaPOS4_0, _1, and _2

I thought they were identical but I see this morning theyre not?

Where should it create this file? Is it because there is already one ina cirtain locationcalled SambaPOS4.sql?

Edit: I even went back to basics and followed the tutorial here: How to migrate from SQL Compact Edition (sdf file) to SQL Server 2012 Express

But still no Joy, rather than creating 1 database, it creates three…

Edit: I tried on another computer and still get this:

ill start again from scratch… but I’m not confident ill get it.


Are you trying to convert from CE to SQL? Did you tried this one?

I did try this but didn’t have the option to “Add SQL Server…”

I don’t have the till here now cos I’m at home but I have the database on another laptop that I do have here. Ill give it a go on that. Ill keep you updated. Thanks for your patience with me.


Here is what I got… looks liek I need to upgrade the database file first??

OK. Seems like I’ve accidentally pointed incorrect setup. You need to download Standalone 3.7 for SQL Server Compact 4.0

I’ve corrected tutorial. Can you try again?

1 Like

Thanks for that emre, seems its still not being helpful… there must be something im doing because its doing this on 2 machines?

Its again giving me three output files!?

What is the problem with having three output files? It probably splits them because files becomes too big. You should be able to merge them inside SQL management studio query editor by pasting file contents in order.

Also you can try checking SQL CE toolbox settings as it may have a setting to control how it splits files.

1 Like

ok i didn’t know that doh! ill get back to you!