Com Port printer not formatting properly

Im trying to integrate our new surveillance software with samba. Surveillance software is not recognizing sambas print data for some reason. Samba is printing to a com port which is redirected to another com port that surveillance listens on. I am 99% sure its a formatting thats causing my issue.

Look how sambas printout shows on putty:

Look how it shows on the example pos data sender program surveillance company provided. When I send data through this program, surveillance software picks it up just fine.


Is there any way that I can set max character limit per line for com port printer. Or even somehow use new line command? Im pretty sure if I can do that ill be okay.

Is there anyway to allow printing with printer type ESC/POS to directly COM port. I changed my printer type to that and set the printer name to an unconnected epson printer which I set on COM 3 and the surveillance software picks it up fine and formatting is good but i get printer unavailable message from windows every time. So that proves that my issue is COM printer on samba side.

Can you not make a new printer using com3 rather than change unconected one to com3?

No samba doesnt let you set name to com3 for ESC/POS printers @JTRTech

No I mean manually add a printer in windows, use com3 and try generic text driver… then use escpos mode to that printer name…
worth a try

How would I add a manual printer in windows? @JTRTech

Really :-P?

im on windows 10 lol @JTRTech windows 10 tries to search for a printer and wont let me specifiy manual printer.

You can still get to old version on one of the options at the bottom.

Or in win 10;

oh great thanks, what printer driver should I select? @JTRTech

Id try with just generic text if nothing else.

That actually worked, but for some reason seeing ! before every line.

By the way on a printer template how do I actually output this as text to my program. samba thinks its formatting functions @JTRTech

Not sure, what actually do you need to send to it?
Maybe you might be better looking at a script to post/echo to the port…
Looks almost like xml

It is XML.

I basically want to send ticket information in xml format so pos software recognizes it. But samba is reading the xml functions and thinking its for formatting or whatever and it wont show them in the output. is there something i can do to tell samba to not see it as a function but rather just output it as text @JTRTech

Not sure, wouldn’t be a typical use of printer template…
Have you tried putting normal formatting tags on beginning of lines in front?
Scripts defiantly have xml support…

How would I output to port with script. I have never used script feature. @JTRTech

Pretty sure there is a way, sure was going along those lines when tinkering with card intergration as that was xml…
FYI don’t need to get me in every reply :stuck_out_tongue:

Got it by setting printer type to “Text”


1 Like