COMET USB Caller ID Setup Issue

So i got the COMET USB Caller ID to use with SambaPOS.

But im having this strange issue with it. Of course no response at SambaPOS whatsoever.

So i tried to use putty to connect to COM3(My assigned port for COMET USB)
In there, there is absolutely no response…

I typed in AT+VCID=1, pressed enter, there was no response. Even the cursor did not move the to next line.
The arrow keys however work to move the cursor in any direction. Up and down included.

Anyone else ever faced this issue?

PS: I’m located in Thailand. Not sure if there are country specific rules to how the caller id information is encoded.

The Initial setup, the cursor jumps back to begining of the line when i press Enter:

Incoming Call, thats all it shows:

Ok. Changing the Bits per second setting in the device manager to 1200 and connecting via putty, it worked!
I get the number like 062113120897790XXXC
The number i called from was 0897790XXX

however, when in Sambapos, there is absolutely no response when a call arrives. Obviously, i did add the device in Local Settings>Devices.

One thing i do notice though is that i was following this link: Step by Step Guidance on setting up Caller ID Feature which is based on V4. And the settings dialogue is much different from V5.

One thing i notice here is the Match Pattern field. What rules does it use to define patterns?
Like i need to extract 0897790XXX from 062113120897790XXXC.

So at this point… two questions:
• Why does SambaPOS show me nothing when a call comes in.
• If it shows, how do i trim the input to the relevant part.

Your screenshot shows COM10 ? Thought it was on COM3?

No i moved it to COM10 today when i reinstalled it.

Putty on COM10 is able to to read from the Device.
However, the output is not beautiful like the examples i see…

It doesn’t even put a line break between my phone calls, just one long string, and the next phone call is another long string right after…

This is the ouput after making 3 calls.

Any command i enter does not seem to have any response. Pressing Enter just brings the cursor back to the beginning of the line.

So where does this leave you?

That SambaPOS does not recognize the called ID and not display ANY popup. Moreover, each string is not a FULL id number, but there is more. (the number calling start at 089…

Ok, well there is no reason I have seen that caller ID side of samba would have stopped working…
Have you set the initialisation string in samba?

I have tried setting up caller ID, although my modem was a different brand I got it working pretty easily…

As for number format there are many variables on this, network provider being a big part as to how they process caller ID.
Regardless you would be able to adapt within samba once you get samba receiving from modem.

I did set the initialisation string, to no avail.

Is there a way to show in a container what Sambos heard from the CID?

Because i do notice the output from my CID is not the beautiful generic one like:
MESG = 110101
DATE = 0411
TIME = 2356

My output is just one liner string like: “062115510897790537>”

So i suspect sambaPOS did not recognize the string.

Well, looking at the current situation, i do have a string with relevant information.

So, is there a way to make SambaPOS listen to a serial port directly, and i process the incoming string and show as a popup ?

Triggering customer search from the number will be the next step technically.

So we decoded the output from the Comet,

The first part of the string before the phone number is date. There is one character after the phone number that seems very random to us at the moment. Still trying to decode that.

Using Windows 10, we dont have a voice/fax modem on the system. Hoping thats not the cause of a problem.

Worst case scenario:
@emre Can you tell me how to make sambaPOS listen to a serial port and popup the raw data ? and then i create actions and rules to finish that up ?

That is what I would imagine is the match pattern field for, to set which bit of the data is the number.

COM ports are very basic, they only ever handle raw data.

Did you make sure putty etc was closed before trying/starting samba?
Only one thing can listen/connect to a com port at a time.

You need to use regular expressions to extract phone number from raw data. That is configured via match pattern so if you set match pattern as .{4}(.{3}) it skips first 4 characters and takes next 3 characters as phone number.


Yes of course closed Putty before samba… cant have 2 processes listening to the same Port.

@emre using regex to extract the raw data makes sense. But where is the raw data ?

i checked through putty, COM10, Baud 1200 and i got a result… a long string for each call. The phone number is there along with the date-string and that extra byte in the end.

Example: 062118500897790537>

Decoding this:

06 | 21 | 18 | 50 | 0897790537 | >
= month | date | hour | minute | phone number |

Ideally i would expect sambapos to be showing me this long string in a popup is that not right ?
Somehow i dont get anything.

Is there something i missed?

Also tried adding it as Generic modem & Advanced Generic modem… no results whatsoever!
How do i check if SambaPOS is even receiving anything at all… I know the data is generated as putty does get the data. But at sambaPOS there is no way of telling if it got anything or not.

The COMET Modem also has the green light blinking when an incoming call comes.

You need to configure match pattern to see a data.

I have tested CTI COMET USB device and not seeing any issues, testing on SAMBAPOS 5.1.60 Beta. Below are my settings.

Emre, New Countdown feature for the pop-up is awesome. Thank you


Here is my version.dat:
VersionTime=2016-04-13 2009

Do i need to upgrade to V 5.1.6 ?

For just showing raw data do i still need to use match pattern ?
I even tried [\s\S] for match pattern. Still no popup.

Its been over a month, and my COMET caller ID still doesnt work with sambaPOS.

If I need to configure match pattern to see data, can you help me out on the expected pattern? because i have tried many patterns, in the end also tried (?s).* and .* but nothing seems to work. Sambapos does not respond at all.

As mentioned before, raw data from the caller ID using putty is like this:

Decoding this:
06 | 21 | 18 | 50 | 0897790537 | >
= month | date | hour | minute | phone number | extra byte

PS: I’m not using putty and SambaPOS simultaneously as that is just common sense.
@morshed1 i’ve had the exact same setup but no success. My version is 5.1.59, but really doubt that the caller ID didnt work before V5.1.60.

So can anyone help me figure out where i went wrong?
The caller ID responds to incoming calls and does provide a valid output. The only issue is SambaPOS does not seem to be listening to the port. Putty with the exact same settings works just fine.

I have tried:
9600 bits per second at device manager, baud rate 1200 at samba >> nothing
9600 bits per second at device manager, baud rate 1200 at putty >> has output

1200 bits per second at device manager, baud rate 1200 at samba >> nothing
1200 bits per second at device manager, baud rate 1200 at putty >> has output

1200 bits per second at device manager, baud rate 9600 at samba >> nothing
1200 bits per second at device manager, baud rate 9600 at putty >> nothing

as you can see, i have exhausted every possible combination. Including the ones that look fundamentally wrong.
I’m really out of options and a fair lump of money in the drain.

According to this…

So did you tried this?

  • That means skip first 8 numbers take remaining 10.

Also try “Advanced Generic Modem” setup parameters as you did on putty and also set Read Timeout as 100. That changes port listening method.

Try setting entity type name.

Well sorry for that but trying to blind guess the issue is something really hard. Comet is not a device sold in our country so I can’t test it physically.


I have also tested on 5.1.59,58 and earlier version of sambapos and have not come across this behaviour.

Ok, 4 months have passed without any success on the Comet Caller ID
I’m wondering if there are issues with the environment.

I’m using a server for SambaPOS. Added an NVIDIA graphic card. No Sound card on board.
Using a plug-and-play USB sound card dongle.

Noticed in the called ID setup for TRIXES USB 56K External Dial Up Voice Fax Data Modem has some reference to audio outputs. So i’m wondering if that affects my setup as my soundcard is not the usual type. Its a long shot i know… but at this point i’m desperate.

Putty works perfectly with the caller ID. Just SambaPOS does not show any popup.