Creation Method - Quick Sale - Close button problem

I setup a new department for the Bar and changed the creation method so no table or customer is required. My question is regarding the close button.

When choosing close instead of settle it does indeed close and open a new ticket. When I go back into the ticket the status on the order is still new, but I am unable to cancel the ticket. I also can’t void it because it is not submitted yet.

Maybe I just have it setup wrong, but in my mind the server shouldn’t be able to close the ticket screen if there are existing orders. They should be required to either settle the ticket or cancel the item/order.

The only way I was able to cancel the ticket was to assign a customer and then submit it. After that I was able to void it. Any help appreciated on the concept of quick orders using create ticket as the creation method.


That is not default behavior. You have changed something. Did you change any rules dealing with before ticket closing, etc?

PS. The ticket is submitted which is why you cant cancel it but your flow is messed up so its not marking orders as submitted. Somehow you messed up a rule that deals with ticket or order states.

Look at Ticket Closing Rule it should look like this.

Having a Ticket Tag on the Ticket will allow it to be closed, so check for that as well.

You might want to clone the Rule for the Close Ticket Automation Command. Set the mappings for the 2 close buttons so they can only be used in a single Department. You may also wish to Clone the Automation Command so that you can set Enabled States separately for each department.

Basically you will have 2 Close buttons, activated by 2 Rules.

Now constrain the Close button for each department however you see fit on the Button mapping and/or in the associated Rule Mappings and Rule Constraints.

1 Like

Ugh I must be too tired :rage: thanks for cluing me into the ticket closing rule. I didn’t see it at first.

I had setup two different closing ticket rules for using different print templates with different terminals based upon where the terminals are located. I just added the terminal to the rule and I was all fine. Ugh… was I would’ve seen it sooner.

Thanks for the help guys,


1 Like