Credit Card integration Local & Program Setting Module are Blank

I may be jumping the gun on this. I am waiting for approval for International Bancard integration (US). I was looking through the KB docs and noticed when I upgraded my development computer to version 5.3.2 the Local Settings → Module Settings & Program Settings are blank.

I do see an IB_Controller file in ModuleSettings folder:

Is there instructions when approved on how to set up the Local Settings? Or are they enabled with a licensed database?

You will need to purchase the free IB license for your account as well.

First you need the latest version of SambaPOS 5.3.2 and then you need to go to PaymentController folder inside root sambapos and copy the following files to the root Sambapos dir. Only copy the two highlighted in the screenshot. DO NOT copy the PaymentControllers.dll file

I copied the 2 files. I now have Program Settings → Module Settings but still nothing in Local Settings → Module Settings.

I’m using/testing Ver. 5.3.2 on my unlicensed development laptop.

I’m thinking with this statement you’ll need your dev install activated.

You need to delete the files you found in documents. The ones in module settings folder. Then restart sambapos

You have some residual files of old setup.

1 Like

Bingo! That worked! It’s showing up in both section now.

One other slightly off topic question. I’m using Workday Payment accounts for each till, where the payment account name would be Credit Card-Admission Till, Credit Card-Snack Counter Till, Cash-<till name>, etc. When the till is cashed out at the end of the day, a credit entry is made to bring the balance back to zero for each account and a main payment account is debited.

We will be getting 2 terminals. Would having credit card payments for each till be necessary since there should not be anything in credit cards to cash out?

After copying the 2 files over, I could get the international Bancard to show up in both section. But after a short time, SambaPOS would forget the Local and Program settings, leaving a blank screen in the respected areas.

I ended up setting the permissions to the 2 files to full access, then it seemed to remember the settings. Is there any harm to setting the 2 files to full access?

That is due to a settings file stored in Documents\sambapos\modulesettings folder. Delete those txt files and restart and you should be fine.

I tried that…a few times. Originally there were 4 (or 5) files in that directory. Deleted them. Restarted Samba. 1 file would appear again, the IB file, but it would not show in Local settings. Restarted Samba again, and still would not show.

I copied over the 2 files again, asking to overwrite and needing Admin permission. It would work after that for a little while then stop working. That’s when I thought it was a user permission issue.

Hmm odd i have not seen that before.