Custom Scale Question

HI @emre I just try to connect a scale with pos I am getting an error, could u pls help me

I am using CAS PD II
these are the ecr types they got

sorry @emre this problem is being fixed, i was using the previous version.
now only thing is i need to know which type function i should set my scale.
type 0- type 5?

Did you tried connecting to your scale with putty as demonstrated on tutorial? How it responds?

yes i tried but no response.
i tried another software as well but no response.
is there any other option i can check
i think the scale should send weight data once we place item on it?
my scale is same CAS brand so tired with the existing configuration if CAS ER.
Thanks @emre

Does it communicates through serial port? We support that type of connection and if it supports you should be able to see a response with Putty when you scale something. We need to see that response to be able to configure Custom Scale.

HI @emre , not getting response , only getting an “A” when i try to change the mode of Scale.
Scale has got 7 mode, from type 0 to type 6, I tried with all modes but no response on putty.
I talked with a cas scale technician and he was like, scale should get some data which ask for weight.
the scale will send the data of weight.
just wondering how does CAS ER works, I mean when we place a weight, scale should start sending the weight data via RS232
isn’t it?

HI just tested with driver software of CAS PD II it giving a reply

@ashrafsidhik when you place weight on CAS ER, it automatically streams weight data without the need of asking for it.

When I go back to my office I’ll try to obtain that model and check how it works but I won’t suggest it since you’ll need to click to a button to be able to start (ask-read) operation.

@emre thanks a lot, kindly check it and replay please because we already spend money on it. I thought CAS ER and CAS PD-II same brand so it should work same way.
Thanks again for your attention on this topic.

Hopefully in our country we can replace or request a refund in 15 days without questions asked :slight_smile:

hi @emre I got bit improvement can u help me moving forward?

hi @emre is this anything to do with scale, because am getting this dialogue box, after I added custom scale.

Can you please disable custom scale and let me know if the error message disappears or not?

yes it disappear when i turn off the scale.

when i click ok on the dialogue box the sambapos shutdown !

hi there, i too tried Custom Scale with Towa ozV, but no result

Which dialog box? Custom scale settings?

No, this one - “The calling thread must be STA, because many UI components require this”

OK. I’ve made few changes for next release. If it solves STA issue we can create a custom regex for reading weight.