Customer Receipt does not print all products [Resolved]

I would guess the reason is the order is selected so it is printing the selected order only.

EDIT: I was correct if you add Close Ticket action to execute first it will work however this is not a good fix because it messes up normal orders where you do not have Orders selected.

EDIT: Found a fix. Go to your Execute Print Bill action and toggle the Ignore Selected Orders option.

Since the Execute Print Job action has the option to Ignore Selected Orders I would assume there is a good reason this behavior was happening. Due to this being a configuration issue I will change this thread to Question as it is really not an Issue.

So a good reminder is if your business needs require printing bills in middle of selected orders then you must set the action Execute Print Job > Ignore Selected Orders = True.

1 Like

Good find on the fix @Jesse. I too thought of playing with that setting, but I set it False instead.

It seems counter-intuitive to me, since the Order that is selected Prints while the Order that is not selected does not print.

Nonetheless, your fix works! Nice job!

I see what your saying and its probably the wording of the Action’s option. Although I can not think of a better wording lol. You would think that setting would tell it to print everything BUT the selected… The reality is it is telling it to print entire bill regardless of selected order and the default behavior is to print only selected order.

1 Like

Great! Thank you @Jesse @QMcKay

I assume this should not break anything else. LOL.

I can not think of anything this would break as Print Bill action via a Button is pretty straight forward and a static behavior. Even automated Print Bill functions should still work fine unless for some reason you had a specific setup to Print ONLY selected orders… but even then you could still use the action separately preserving the button.

Thank you @kendash. Your help and dedication is always appreciated.

In fact I do have a button and print job that prints only selected Order lines, and it is set as follows:

1 Like

Its really not a big deal but I would think default behavior should be it prints entire bill. Maybe @emre could look at this at some point but it works so its not a big deal. The setting of False seems redundant if default behavior is False. Maybe there is a reason for it that I have not discovered.

2 Likes