Database backup error (3 terminals & Server)

Hello all, I am having difficulty backing up my database.

SamaPOS v5.1.59
Server SQL express 2014 , 32bit

I have V5 with backup tools.

When I try to back up on one of the clients, I get the error “The system cannot find the path specified”

When I try to back up on the server i get “access id denied”

I am sure I must have over looked something simple :slight_smile:
When backing up on a multi terminal system, can it be done on any terminal or must it be done on the server ?

The user that runs SQL Server service does not have access permission to C:\Database Backup\ folder. If possible store your backups under a different drive like D:\ or give access to your backup folder.

1 Like

Thank you Emre,
I successfully backed up to a flash drive (i:) on the server.

I guess new drives have the everyone group - full control access.

So I edited the security permissions of my C:\Database Backup\ folder and did the same, added everyone group and gave full control.

The Backup is working now, Thank you again.

I was unable to identify the user that runs SQL Server service runs under.
All I found was this …

Is the user SAMBAPOS5 ?

I’m not familiar with that Windows version but for Windows 10 Service Details dialog have a Log On tab. I can see / change service user from there.

Log on as Column also displays service user.

I generally change SQL Server user to Local System for development purposes. That user have more privileges than a standard SQL Server user.

1 Like

Perfect, Thank you :slight_smile:

Or add permission for the SQL service with the NT Service\MSSQL$INSTANCE_NAME.
Opening the folder to anyone is potentially opening to anyone on network to delete etc.

1 Like

Thank you, I will change from everyone to the SQL one. Thank you for the advice :slight_smile:

Auto Backup question

I have a server and 3 tills. I do not actually use the server at all for POS.

So i cannot use the backup on close of work period option as the clients do not have the database. (is that correct ?, cos i tried and it failed)

IF i end the work period on the server it backs up perfect auto to a dropbox folder , but as I said i will never be running POS on the server , its just there to hold the database and look cool.

Is there a way i can automate the back up process ?

I was thinking of emailing my self a copy but after thinking about it , I am still not ending the work period on the server , I end the work period on the clients.

Do you know of a way ?


What error do you get?
I would imagine permission/access.
Backup directory is like printers and needs to be available to each machine for it to work on that machine.
Alternativly you could try broadcast message and rule for received mapped to server with a backup action etc.

1 Like


The error I get is the same for all of the non server tills. I set the backup destination as a flash drive (G:) to avoid permission issues while testing.

on TILL 2

on TILL 3 - i tried a few different drives - no joy

on flash drive E:

on server - never used as a till, just used to hold database.

That broadcast thing looks cool, just looked it up.

Its confusing sometimes what settings / data is shared across all terminals and what settings / data is unique to terminals.

Only noticed now, that the destination path for backup is unique per terminal.

But back to the broadcast message - very interesting :slight_smile:
This is a solution for me - Thank you

If USB stick if in server the other terminals wont see that!!
You would want to share the drive and then map that share to the same drive letter on each terminal.

Hmm, ok, thought it was shared over them all but point above still stands, usb drive in one machine wont be accessible on another, thats windows side not samba.

The backup event/action happens locally on the terminal your on, not the db machine as the db machine doesnt even need samba in theory just SQL.

1 Like

Hi ,

Sorry for the confusion, the USB was not just in the server.

I tested a manual back up on each pc , (the server and the 3 terminals)

For each test i attempted a manual back up with …
1, local folder with correct permissions
2, External USB storage device.

The test failed each time except on the server. which worked with both the folder and the USB.

This is why i concluded the backup operation can only be run on the PC with Microsoft SQL express database running.

The other 3 terminals point to the server and work perfectly for POS and reports etc.

Im still new to this , but I assumed the database was copied from the server on startup to the clients to improve speed, this is why i guessed there should not have been a problem using the backup operation on any PC.

But it appears, at least for me, that i can only complete a backup operation using the built in back up module in sambaPOS that is running on the server.

Do u have a multi terminal system ?
can u backup on any terminal ?

Thank you

Im pretty sure I can but now you say it you have me doubting myself as never actually thought about what PC I was on just that I was doing a backup…
However all my machines are HDD clones so all users etc are identical so never had many permissions type issues.
User on PC is not there permission needed, think it is more about SQL access to the folder.