Date not printing with correct format

I am trying to use data from the SambaPOS reservation system to print a reservation card for the table. This is my printer template
image

And on the preview of the SambaPOS editor all looks good
image

However, when printed it drops the date from the top left corner
image

If I now remove the date formating tags
image
and try to print, it prints date and time
image

I would like to get this to print just the date and in the format I want. Can anybody see what I am doing wrong?

The printer is an Epson TM-T82 ESC/POS emulated printer.

Try formatting the Local Setting before update action or inside the update action.

Sorry, don’t understand. The only action is to execute a print job which in turn uses the specified print template. Can you explain more

{LOCAL SETTING:RsDate} is not a native setting.

It means in your automation Rules there is an Update Program Setting action which updates this setting called RsDate with a selected date.

Its a viable option to format it to dd-MMM-yyyy format before updating it.

Try removing the quotes around the local settings (keep them around the formatting) in your printer template.

—Edit—
You have the correct formatting.

Try using double [ around it.

Write it like this:

[[=FD('{LOCAL SETTING:RsDate}','dd-MMM-yyyy')]]

Thanks for the suggestions

Adding an extra set of [] simply gives [] on the printout, but unfortunately, still no date

RsDate comes from the Sambapos implementation of the reservation system. As far as I can see there is no ‘Update Program Setting’ associated with this. However, following your suggestion I have added one before the print job as follows
image

And now the card is printing with the correctly formatted date so thanks very much for that

3 Likes