DB Task gone wrong, please help


I’ve tried one of the tutorials to create a DB Task to “copy Menu Items”. Surely I’ve done something complete wrong and now when I login to the System I get the following Exception Error and the program closes. Any suggestion on how I can fix it? I did made a back-up of the DB but I am unable to restore the DB because of this Crash.

[Exception Info 1]

Top-level Exception
Type: System.Reflection.TargetInvocationException
Message: Exception has been thrown by the target of an invocation.
Source: mscorlib
Stack Trace: at System.RuntimeMethodHandle.InvokeMethod(Object target, Object[] arguments, Signature sig, Boolean constructor)
at System.Reflection.RuntimeMethodInfo.UnsafeInvokeInternal(Object obj, Object[] parameters, Object[] arguments)
at System.Delegate.DynamicInvokeImpl(Object[] args)
at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Int32 numArgs)
at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Int32 numArgs, Delegate catchHandler)

Inner Exception 1
Type: System.NullReferenceException
Message: Object reference not set to an instance of an object.
Source: Samba.Modules.PosModule
Stack Trace: at Samba.Modules.PosModule.MenuItemSelectorViewModel.UpdateCurrentScreenMenu(Int32 screenMenuId)
at Samba.Modules.PosModule.PosViewModel.OnTicketTypeChanged(EventParameters1 obj) at Microsoft.Practices.Prism.Events.EventSubscription1.InvokeAction(Action1 action, TPayload argument) at Microsoft.Practices.Prism.Events.EventSubscription1.<>c__DisplayClass2.b__0(Object[] arguments)
at Microsoft.Practices.Prism.Events.EventBase.InternalPublish(Object[] arguments)
at Microsoft.Practices.Prism.Events.CompositePresentationEvent`1.Publish(TPayload payload)
at Samba.Presentation.Services.Common.ExtensionMethods.Publish[TEventsubject](TEventsubject eventArgs, String eventTopic, Action expectedAction)

Download Micrisoft SQL Server Management Software don’t know what it call exactly just search SSMS should show up. And you can restore database directly.

1 Like

Thank you, I’ve tried restoring but still got the same error. I did however manage to remove all the SQL DB and re-installed Samba. I’ve then restored the DB and everything seems to be working fine.

1 Like