Double confirmation for single automation task executed from within entity screen

The automation command is only fired from one place. Here’s what happens:

The debugger only shows the automation command once:
24-04-2020_19;59_1587779951_Samba.Presentation

Expanding the drop down I don’t see any other call to an automation command:

I’m confused why the double confirmation. Thanks for any help.

EDIT:

It happens with another confirmation-enabled automation command

Need to show the rule and action

THe one that’s firing has a lot of actions. I’ve tested with 5.2.26 and the behaviour is the same.

I created a test automation command test (on 5.3)

24-04-2020_22;23_1587788624

24-04-2020_22;22_1587788545

24-04-2020_22;25_1587788759_Idle

It happens to me but with confirmation with admin pin because I have two users as Adminatrator. I dont know if is a normal behavior

I should add that confirmation pops up only once when called from navigation screen

I’m wondering if confirmation has to be done through action/rule within an entity screen.

On your automation commands button, is it set for confirmation? And execute once?

If that doesn’t fix it, what version are you using?

I never noticed the ‘Execute Once’ option. When enabled, there is no change to operation.

I’m on 5.3 right now. I tried on 5.2.26 and the operation is the same.

What if you turn confirmation to “None”?

Command fires properly without any confirmation.

I’m at a loss…Maybe try constrain out each action starting from the bottom.

p.s. Sorry, I missed the version numbers you put in earlier in one of your posts.

Execute once is to do with loops or something like that I think.
Confirmation is the prompt

Meh, no worries.

I tried with 5.2.22 and it’s the same.

Normally I’d be with you. However, with the test action there’s one command, action, and rule. There’s something else I think.

Neither the test nor the close shift rule contain any actions that fire an automation command.

When selecting ‘No’ at the second prompt for confirmation, the rule debugger does not show anything happened after selecting ‘Yes’ at the first prompt for confirmation.

25-04-2020_08;17_1587824247_Idle

You don’t have another command with similar command vame do you?

Nope. I created a completely new automation command to test.

Hello, I had this same issue.
For me it worked when the ruel debugger was disabled and when the rule debugger was enabled it made this exact thing. Try this.

I checked and this occurs regardless of debugger state. I’ve achieved my goal with actions/rules but it would be nice to not duplicate built-in functionality. Thanks for the suggestion!

did you restart SambaPOS after disabling/enabling rule debugger?

1 Like

Arrr, yer, remember rule debugger had a weird query like that.

Yep - it’s been restarted many times since.