Epson t20ii with Esky® ES-CD01 kick code

hi new to this ,i had no problem setting up server database 2 pos ,printer etc followed guide ,i do have technical background. then we arrived at the part where all software is installed database etc .had trouble finding a good guide to do menue reciept etc but i figured it out its all on the site just not in 1 guide .
brings me to the only problem i have drawer kick comand .ive tried all on tutorial nothing the t20 code does not work on t20ii ,and google search just brings up others having issue but no solution .i have the epson t20ii configuration utility, i slo followed samba pos guide for printing making rules print job template to open drawer no luck .
i need help with this matter ,using system for ice cream store quick serve ,any help please t20ii drawer will not open thx


It lists the kick code for that model as;

Which would be <XCT>27,112,48,55,121 in your template.

If your strugling you may want to check if there is a dip switch setting to enable/disable draw kick.
Also whats the cash drawer? Some draws use different pin combination or normally open/normally closed circuits.

PS. changed to question rather than issue :slight_smile:

1 cash drawer is esky es-cd01
the other is POSL-420

not sure if tm20 is the same as tm20ii printer ,i did try that code . iwill look for switches thx

The ii is ther version number, would say it would be unlikely to change, this is the same code as TM88 veriosn i, ii, iii, iv and v
There are some codes relating to versions ending in P, not sure if that mean parallel, what port does your printer use?

also when installing tm20ii does it matter which driver i install it gives below options
advanced printer driver 5.01a
opos adk ver 2.7
opos adk for .net
java pos adk

printer is usb direct to pc

Not sure, only used TM88 and U220 models from Epson, cant remember that options.
Since Samba requires .net to be updated if pc not up to date I would guess .net

ok ill try installing .net i did not c any dip switch will get back to u

There is an open draw test in the utility;
If that doesnt open is issue printer side like pins or enabled, if it works it will most likely be the code or your use of the code.

it does not open during utility i tried that many times

i have 2 x t20ii usb printers epson and 1 st650 star ethernet kitchen printer using star utility i can open register drawer .but i am having no luck with epson , the epsons will be used with drawers ,i will keep trying just wanted to add this using tm20 ii utility drawer does not open

partly solved . in utility buzzer was enabled so i desabled it it sent comand to printer after that when i did test drawer it worked .so in samba pos if i press open drawer it does open .but if i put tender amount and hit cash it does not open ,sounds like i got more config to do . thank u for pointing me the right direction solved

1 Like

I generally have my open drawer command on a seperate template,
No Sale/Open Drawer command just prints that template and on payment processed = cash rule have the open draw print
Find this works better and more flexible than putting the open draw in the actual receipt template.