Error Message Invalid object name 'VersionInfo'

I am setting a new client that already has POS in the place. they want me to install my pos (SambaPOS V5). I am using the SQL 2014 already installed on their server PC because SQL express 2017 could not be installed due to minimum requirement issues.

Can anyone help me with this issue?

Can’t connect to the database with the current setting. You can check and modify the connection string shown below.

Error Message Invalid object name ‘VersionInfo’.

Data Source=HEAVENSADMIN; User Id=dbsa; Password=SambaPOSV5; Database=SambaPOSV5;

Data source for sql express would usually have a host and instance
A version issue would often be if you tried to restore backup from 2017 sql to system on older sql but it doesnt ask for connection sting in that scenario.

I didn’t get you. Can you please explain further or send me a link.

This is a fresh connection and installations. I’m not doing any backup restore

In connection string when using sql express typically your data source would have host and instance.
Host is the pc worh database. If local to that machine you can use localhost. Then instance name which you would have set when installing sql.
My data source is EPOS-SERVER/SAMBAPOS
epos server being name of pc and sambapos the instance set when installing sql.
Cant remember is its forward or backsplash.
Think its forward

But that error doesnt coinside with that being the issue.
Sounds almost like the database doesnt have or has invalid version info.
If it’s a fresh install either change database name and samba will create a new db for current version or try deleting the database of that name.
Perhaps you created blank database rather than let samba create one with basic info needed.

I change my data source to HEAVENSADMIN\MSSQLSERVER

computer name HEAVENSADMIN
Instance name MSSQLSERVER

Error Massage:
A network-related or instance-specific error occured while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that the SQL Server is configured to allow remote connections. (Provider: SQL Network Instance, error:25 - connection string is not valid.)

Data Source=HEAVENSADMIN\MSSQLSERVER; User Id=dbsa; Password=SambaPOSV5; Database=SambaPOSV5;

Please note that I am trying to establish a database connection at the server

Please see my seccond comment.
The error you got isn’t what would usually be expected for bad connection string. So based on what you originally posted sounds like another issue.

Make sure the server is running. Sometimes, for me, the service fails to start after reboot.

Again is service was not running it wouldn’t mention version, it would say about connection and ask to check connection string.
Can you show screenshot of your error to confirm exactly what your seeing @Okokhue_Ferdinard

I followed this step by step procedure but i used 2012 sql

My error message is ths:

I do no have permission
do you think I should create another user?



Did you definitely select mixed mode auth when installing sql express?
Your string earlier showed this

Where have you got dbsa from? Unless you have done something to change mixed mode username would be ‘sa’.

I solved the problem remotely. Multiple SQL instance is installed and user name and password are incorrect.