Export to file error

someone help clear this error

See if the exception is logged and post it here. It’s located at %USERPROFILE%\Documents\SambaPOS5\log.txt

User Explanation:

SERVER said “”

[Exception Info 1]

Top-level Exception
Type: System.ComponentModel.Win32Exception
Message: The specified printer has been deleted
Source: Samba.Services
Stack Trace: at Samba.Services.Implementations.PrinterModule.Tools.PrinterHelper.GetPrinter(String szPrinterName) in C:\Users\Vehbi\Documents\Source\Repos\sambapos-v5-pro\Samba.Services\Implementations\PrinterModule\Tools\PrinterHelper.cs:line 15
at Samba.Services.Implementations.PrinterModule.Tools.LinePrinter.StartDocument() in C:\Users\Vehbi\Documents\Source\Repos\sambapos-v5-pro\Samba.Services\Implementations\PrinterModule\Tools\LinePrinter.cs:line 183
at Samba.Services.Implementations.PrinterModule.PrintJobs.SlipPrinterJob.DoPrint(AppState appState, String[] lines) in C:\Users\Vehbi\Documents\Source\Repos\sambapos-v5-pro\Samba.Services\Implementations\PrinterModule\PrintJobs\SlipPrinterJob.cs:line 21
at Samba.Services.Implementations.PrinterModule.PrintJobs.PrintJobCache.Print(AppState appState) in C:\Users\Vehbi\Documents\Source\Repos\sambapos-v5-pro\Samba.Services\Implementations\PrinterModule\PrintJobs\PrintJobFactory.cs:line 80
at Samba.Services.Implementations.PrinterModule.TicketPrinter.InternalPrint(AppState appState, Ticket ticket, PrintJob printJob, Func`2 orderSelector, Int32 copies) in C:\Users\Vehbi\Documents\Source\Repos\sambapos-v5-pro\Samba.Services\Implementations\PrinterModule\TicketPrinter.cs:line 82
at Samba.Services.Implementations.PrinterModule.TicketPrinter.<>c__DisplayClass17_0.b__0() in C:\Users\Vehbi\Documents\Source\Repos\sambapos-v5-pro\Samba.Services\Implementations\PrinterModule\TicketPrinter.cs:line 77
at Samba.Services.Implementations.PrinterModule.AsyncPrintTask.InternalExec(Action action, ILogService logService) in C:\Users\Vehbi\Documents\Source\Repos\sambapos-v5-pro\Samba.Services\Implementations\PrinterModule\AsyncPrintTask.cs:line 32

Is that the only exception? Is there perhaps an inner exception listed? Maybe clear the log, then retry the export and capture the exception again.

I say this because I’m not quite sure why the printer module would be involved in the export. The export just generated JSON from the selected configuration objects. But, I could be entirely off-base on this one.

Most recent logs should be at the bottom of the file, I dont think this error you pasted is related to the one you are experiencing

When I clear the log file and try to export, the log file doesnt register anything it remains blank. Even when i restart the POS and the PC

Without the exception/stack trace it will be very hard to figure out what’s going on.

Hi there,
Even efter upgrading it to 5.50, the error still persist. Can

It means you must be trying to export a configuration of print job and the printer was deleted that is inside that print job… something similar… Whatever you are exporting it has a printer in it that does not exist anymore in sambapos.

Can you give us more info to go on… We are in the dark and just guessing. What are you exporting?

Thanks Jesse for the reply,
I have taken my time and gone through print jobs, printers and printer templates . as per the advise above I have counter checked and all are ok.

Please see the screenshot below to answer your expor question

Am trying to export settings go file


he messaged me in private and sent me his database, the issue was this.

How it came to be I do not know, but I changed table name to dbo.TaskTypes and the Export to File feature worked just fine.

P.S. I also thought he was referring to report or data export :sweat_smile:


The only way that can happen is someone manipulated it. That table does not randomly change. But thanks for that.

Thanks alot. I renamed it as per your directives and it worked

1 Like

Please advise on how to secure my db access on mamagement studio. It has a username and password already, but remember when one of the machine looses connection to the database, the management studio username and password are displayed on samba dialogue box where everyone can see the credentials

I made a utility to launch SambaPOS without having to worry about that error showing.

Keep in mind, too, that one can log in to SSMS with integrated security.

1 Like