[Fixed 4.1.76] Dine in/To Go Button (Ticket Tag) not working in v4.1.75

issues in Dine in/To Go Button after Download SambaPOS 4.1.75 and updated the button not work any more

Can you explain a little more. That button is not default feature it is user built. It is more than likely something else causing it. 4.1.75 works just fine with the button as laid out in the tutorial I have tested it. So your issue may be something else if you can explain more or give us more insight we can help you figure it out.

1st what part of the button is not working?

2nd Check your rules, and actions make sure no changes were made.

3rd check your Ticket Tags make sure no changes.

Maybe give us some screenshots of your setup we can look at

Be sure mapping is still set correctly for rules and automation commands.

Interesting. Mine is broken too. It works on 1st click, but successive clicks have no effect. The Button isn’t updating properly - it isn’t Toggling!

Very strange fresh import of it and mine is toggling. I just tested to be sure. Its toggling.

EDIT: Ok i was wrong it is toggling if there is no active ticket yet. Soon as I add an item it stops toggling. Maybe that helps you @emre

I’ll take a wild guess to say it has something to do with the non-requirement for “hard-refresh” @emre mentioned, which came about in v4.1.75 via this discussion regarding Automatic Customer Discounts:

EDIT: I removed the Refresh Ticket Action from the Rule, and the Caption on the Automation Command Button properly toggles between To Go and Dine In, on the second try, and each successive click, unless you add another Order Item, then you need to click it twice again for the Caption to change.

Unfortunately, the Ticket does not properly show the current value for the Ticket Tag.

However, the Print does show the proper Tag Value.

I just tried using Ticket State instead of a Ticket Tag for this, and I have the same results as described above.

  • It will not toggle with Refresh Ticket Action in the Rule.
  • It will toggle without Refresh Ticket, but the display does not update until you add another Order Item, at which time, the Caption becomes incorrect until second click.

I’ve uploaded a test release for 4.1.76. Can you please let me know if it works fine or not?

:warning: Don’t forget backups !

1 Like

It also has something to do with the Toggling of the Automation Command.

I just tried a different method where I do not use a Toggle; instead I use Ask Question, then set the State (likely works with Tag as well) to [:CommandValue] coming from the Ask Question, and Refresh Ticket. That works just fine.

I’ll give the test release a try…

v4.1.76 Test Release fixes the issue.

Back to working as normal, using Automation Command Toggle Values and Refresh Ticket Action. Works equally well with Ticket Tag and Ticket State.

Thanks @emre!


Sorry was away for while after i posted. Good to see it was fixed. When I thought it was working as normal I was just doing a quick test and didnt think to actually add an order as it didnt dawn on me that it would be different.

PS @emre i see the fix for reports was in this as well. I am very happy that was annoying.

1 Like

Great to hear that. Doing it without resetting actual layouts was a little challenging :slight_smile:

1 Like

4.1.76 Released. Please re-download if you’ve already installed 4.1.76


1 Like

It works after updating to 4.1.76 thanks alot I do appreciate