[Fixed 4.1.78] DB Tools Import not reproducing Multiple Actions of same name in Rules

I exported some Rules that contain multiple Actions of the same name, and when I import them on my Production System, only 1 Action appears (the last of the multiple Actions).

you can check the exported file and see if in the file on the rule the actions are duplicated or not…


Yes, they appear to be in the export. I can see 4 Actions here. This isn’t the only Rule that failed to import properly. All Rules that have multiples of the same Action seem to import only the last of the multiple Actions.

"AppRuleMaps":[{"DepartmentId":0,"TerminalId":0,"TicketTypeId":0,"UserRoleId":0}],"ConstraintMatch":0,"EventName":"UserLoggedIn","Name":"RU HH MT 15-17 App Started","RuleConstraints":"[{\"L\":\"{DATE:ddd}\",\"N\":\"4ctjzldoHG\",\"O\":\"Matches\",\"R\":\"Mon|Tue\"}]","SortOrder":20,"Tags":"discount,HH"},{"Actions":[{"CustomConstraint":null,"Name":"AC HH Store HH DateTime","ParameterValues":"HHname=HHstartDay`HHvalue={DATE:ddd}","SortOrder":10},{"CustomConstraint":null,"Name":"AC HH Store HH DateTime","ParameterValues":"HHname=HHstartTime`HHvalue=1340","SortOrder":20},{"CustomConstraint":null,"Name":"AC HH Store HH DateTime","ParameterValues":"HHname=HHendDay`HHvalue={DATE:ddd}","SortOrder":30},{"CustomConstraint":null,"Name":"AC HH Store HH DateTime","ParameterValues":"HHname=HHendTime`HHvalue=1345","SortOrder":40}]

I think I ran into this before… maybe i imagined it but I thought I brought it up once before. I thought it was fixed as well… maybe it has reared its head again?

Then again I have taken a lot of nyquil

Aww too bad. I’ve heavily relied on action names not to duplicate existing action references… I don’t think I’ve fixed something like that before.

I think it was the nyquil lol.

Hmm… never tried that.works better than Chivas?

I dont think either of those work better than a caipirinha…



That small green tick indicates next version should handle that fine :slight_smile: I’ll be happy if you can let me know if it works.


Fixed and working properly as of v4.1.78

Thanks @emre!

1 Like