Forum software acting up?

Is it just me, or is anyone else having strange behavior with the Forum?

I cannot copy from Paint and hit Ctrl-V to paste an image in the message box anymore… this bothers me greatly.

And when I hit Reply, my cursor used to focus to the message box, but now it does not… I need to click in the box before I type.

I use Firefox (42.0 as of this writing).

I’ve recently updated forum but didn’t noticed these issues. (I’m using chrome). Clearing cache might help.

I’ve noticed some editor shortcuts changed. That bothered me…

Yes!

Used to be Ctrl-K for code, but now it is Ctrl-Shift-C … what a PIA that is!

On my firefox focus seems working fine but unfortunately pasting images does not work. Hmm… hope they’ll fix that soon.

Works on Chrome…

Cleared cache, no change.

I just highlighted the above and click Quote Reply. It put the quote in the box, but my cursor was not there.

And not able to paste images - I cannot live with that and expect to provide expeditious support using screenshots here.

Guess I need to DL Chrome… I really like FF. :crying_cat_face:

BRB, BIAB, downloading.

My cursor works fine but your right I cant paste screenshots either. Im in latest firefox. I just downloaded FireFox for my iphone even lol.

Using Chrome now for this site only.

I can paste Images no problem.

The cursor/focus thing is still driving me crazy.

And the changes in KB shortcuts is making me mental.

I am having way less fun than I used to. Implore them to fix this, or revert the changes… they are behaving like MS by moving stuff around and changing it for no reason when it worked perfectly fine before.

I’m watching it. Seems like they’re working on it.

Can’t revert as I may miss a critical update. I hope they’ll fix that soon.

1 Like

Hmm, ok that isn’t going to change to the way it used to be. Ctrl-K for code is never going to work again…

Would be great to preserve browser conventions, and ideally have shortcut keys that replicate those of very popular apps such as Gmail, Google Docs or MS Word. I’m referring in particular to:

Ctrl+L - I expect it to go to the browser’s address bar, but Discourse hijacks it to insert a link
Ctrl+K - I expect it to insert a link (as it does in Gmail, Google Docs and Word), but Discourse made it add backticks to the selected text (something I personally always do before and after typing that piece of code).

We should definitely normalize on keyboard shortcuts as seen in other popular web apps.

Unfortunately, even Ctrl-B and Ctrl-I (standard for bold and italic respectfully) behavior has also changed… in fact, they don’t work at all as of this posting - I need to use the buttons instead Hopefully they fix that.

Even Ctrl-Shift-C for code does not work, at least in Chrome - instead that shortcut brings up the Chrome Dev Interface.

Copy/Paste still works for me in Chrome 46.0.2490.86 on Windows 7

Yes, copy/paste works in Chrome. But in FF 42, you cannot copy/paste an image.

The focus issue and standard KB shortcuts are really aggravating me though.

Seems like firefox pasting fixed.

We’ll wait until they release it though.

1 Like

Firefox started working but shortcut issue still remains.

1 Like

So just when I tried to go back to using FF, I see this. It just keeps getting weirder…

And NO, I did not blur this screenshot. This is actually what it looks like to me in FF right now.

EDIT: ok, too quick to accuse FF. It looks the same in Chrome as well. WTH is going on here now? LOL

LOL he used the SPOILER tag.

[spoiler]
If you use the tag it will cause it to blur until you click on it.
[/spoiler]

Just click it and it will show.

its [spoiler] XXX [/spoiler]

2 Likes

:stuck_out_tongue_winking_eye: Good to know. Thought I might be going crazy. And I haven’t even had a drink today… :wink:

lol. I tried to temporarily disable text… Now it should appear fine.

1 Like