GloriaFood Online Order Plugin Error

So I bought the Integration Module for $99 and I’m getting this error:

Is Message server setup to run on port 9000+

Did you setup the app and permissions in SambaPOS Correctly? I see you did not set the password accordingly.


The tutorial said to set the password to that number.

They must have updated it. That generally is an issue with the app settings in sambapos or Message Server setting.

So I did something wrong along the way, right?

Probably I am not sure. Can you show your app settings? Users and permissions?

When I had that problem it was not connecting to message server correctly. Is message server on the same machine?


try http://localhost:9000 also make sure you installed message server to port 9000+

Try turning firewall off. Try loggout out of Sambamarket in SambaPOS shutdown, restart sambapos then log back in. Also try restarting message server.

Firewall is already off.
Logged out of the Markets thingy.
Turned off SambaPOS
Turned on SambaPOS.
Logged in on the Markets thingy.
Turned off SambaPOS
Turned on SambaPOS.
Still gives the error.

How do I restart message server?

In the search bar of Windows Taskbar search for services then open it. Find sambapos message server and choose restart.

Still the same error.

Hmm strange. What version of Sambapos are you using?

I am using version 5.2.14

You dont have any of the old versions installed do you? Try removing Sambain and reinstalling it.

I downloaded the install exe fresh from the website 5 hours ago. Never installed it before.

Uninstalled and reinstalled.
Double-clicked the icon and I immediately get the error.

Edit: My previous settings were still there, even after I reinstalled it.
Edit2: Tried to Run as Administrator. No luck.
I am using Windows Server 2016.

This may be a bug with Windows Server. @VehbiEmiroglu will need to look into it.

Thank you for troubleshooting it with me.

1 Like