Go Tablet Printing Issue

This is another location I worked on today,

just installed this 1 tablet.
everything works as intended, SambaPOS receives the order, call waiter sends message and everything.

but the only problem I am having is to do with printing again,

I had a similar set up at another location, which had 10 tablets,
everything but printing is working.

I have attached the log below if someone can help to see what does it mean?
so I know where to look for troubleshooting.


Hi Sushi SambaPOSlog (1).zip (7.2 KB)

PS: I am having this issue across multiple setups, I am not sure if this is something with the settings or Samba Related? I have already emailed this to support as well. Hopefully, we can figure this out.

Any help would be much appreciated.

The exception says “Invalid Printer”. Whichever terminal is trying to print does not have a printer name that matches the one defined.

We try to keep the printer names the same across all terminals so this issue doesn’t happen.

1 Like

Remember usb printers will not work. Make sure it is a networked printer.

1 Like

hi memo, thanks for the help again.

It is a single terminal setup this one with a ethernet receipt printer as well as a ethernet kitchen printer.

After reading your message I am unable to think anywhere for the referred printer name to be?

So if I understand it correctly. This is under printers where we put the names right?

You know what, when I wrote to this. it just got me thinking.

If, the setup has ghost terminals, eg. Terminal that are created but not assigned to machines, will sambapos take that into consideration?

I will go test this when I’m up tmr. Thank you for the information. because all these setups have terminals that are not in use! That might be the problem?

I will post back.

Thanks Jesse
They are all ethernet printers with this setup.

But what memo said just made me think.

I will try deleting the extra terminals that’s not in use tmr. And see if that will solve the problem.

this is what I was talking about when referencing the printer name:


I don’t think unused terminal names would be causing any issues.

1 Like

Hi Memo,

I just checked them all, they are all named the same in all setups,
because the setups are based on the same database with modifications for each location.
Printing is never really much to modify when comes to printers,
as most setups are 1 terminal with 1 receipt printer + 1 kitchen printer.

And I went to check the unused terminals, after some evaluation, I also don’t think they are causing any problems unless they are inuse.

at this point, I think we can only hope that the dev team can make use of the log and provide some help to understand what is causing the exceptions.

I tested this and it’s printing fine with gotablet. There is something you haven’t showed us. I’m not sure what it is atm though it’s hard to tell.

It can be printer driver issue. What printer are you using and what drivers? Is it a cheap generic or a name brand printer like Epson?

Hi Jesse, thanks for the reply.

I am also wondering what is missing from this puzzle,
I have gone through the printing rules multiple times, to see if I messed up somewhere.

The printers are all branded ones, we don’t use any cheap printers,

Hi Sushi is using an Epson TM-30 as kitchen printer via Ethernet
Oba Leeds, the one with 10 tablets is using Sam4s GCube as kitchen printer via Ethernet
All takeaway setups are using Star TSP143iiiLAN as Kitchen Printer via Ethernet

I wouldn’t think if it is a printer driver issue as you can see, on different systems with different brand printers, they all have the same issue.

I start to think if it is somewhere I didn’t set it up properly?
I have been thinking about this for days now. just try to figure it out.
If you can think of anywhere I should double check, please do let me know.

Today I read an earlier post about a similar issue here but it is with Gloriafood. but I think remote printing might be handled the same by SambaPOS?

So, I have defined Department and ticket types at OBA Leeds, and I am going there this evening to test it out. I will see if maybe that will help? I will post back the results.

Also, If you are able, can I DM you a database backup for you to test with your end? and see if it happends? that might rule out if it is a setup issue or a sambapos issue.

to this point, tbh, I am thinking this is probably a setting issue. but I don’t know where I messed it up. :weary:

Do you have anydesk? I could remote in to the server and look.

I can set it up relatively quickly.

I normally use Google Remote desktop, cause its free :money_mouth_face:

One sec

Anydesk is free too :wink:

Is it? I thought it is like only free trail for 14 days then you will have to pay a monthly fee

No it works indefinitely

First thing I notice, It may not change anything, but you are on an older version of SambaIn. I recommend updating it.

You are also on a version of sambapos that is quite older now too. Current version is 5.3.6

I would highly recommend using Custom product tags for print mapping. It can greatly reduce your maintenance on printer routing in the print job. With a custom product tag you can use single Print Job mapping for those tags and when adding new products you can add the tag ensuring it will print properly without having to maintain a huge list of Product category mappings in the print job.

In Print Jobs where it says Product Tag you can map to a custom product tag by using Product Tag=Tag Name

Is there a specific reason you set High Priority to False for the Kitchen Printer action?

You have it set as demo printer to notepad. That will not work. Have you tried it with the actual printer? Or were you just trying to test something?