Help with SambaPOS Mobile Client for Android

Hello everyone,
So, I am now using the SambaPOS Mobile Client for Android and it is very nice, I must say. I have 1 issue, however, very minor. Our waitresses would like a slip to print when they take a large order so they have that to go off of without the need to keep logging in and pulling out their phone to see orders. No problem, I configured a simple template, assigned a print job and printer, Made a new automation command, action, and rule. Tested it on the main terminal, no issues. Updated settings on Mobile Client and selected the print job and did an update. Here is the issue. If the order contains any thing other than food items, like wine, beer, or soda, it puts the order through but the mobile client just assigns it a ticket but NO TABLE. It shows as an open ticket in the ticket window on the terminal, but no table assigned. It works fine if the order is all food, but if there are drinks on the order, it acts up. If i disable the waitress slip printer in Mobile Client settings, it works perfectly again.

I’m surprised it worked at all you have a mistake with parameter for ticket Id in your print action. You put

:[TicketId] it should be [:TicketId]

Ok, I corrected that, surprised it worked also, but the issue still persists.

That shouldnt affect if it assigns a table or not…

You are selecting a table in the app right?

Also remember when you fix an action you must remove that action from the rule save it. then open it back up and add the action then save rule again.

Yes, I have tried it on my phone and our servers have tried it on their own phones as well. They login, select their table, enter their items, and it completes the ticket. The kitchen gets the order on their screen and a ticket is created, but it does not assign the table number to the ticket.If i remove the print selection in mobile client, it works normally.

@VehbiEmiroglu you may need to look at this.

I understand that in this topic some your categories doesnt attach a table to your order. Is this true ? @adam100

Hi VehbiEmiroglu,
I am getting message server connection error. while updating android client. it pulls all data but when i update at front page it gives error. been trying to fix from more than one month. Isa from head office tried as well, would you be able to help me. i can give you my anydesk if you have few minutes to spare. i have purchased two license and not able to use it.

Please email this problem to us via email:
Our support team return to you about this after email

To an extent, yes, that is true. The servers enter their orders into the mobile client. They assign a table number, add the products to an order,and hit close order. It creates a ticket but does not assign it to a table. It only does this if the second print option is enabled, however. The option to print a waitress ticket with their order on it and what they need. If i disable that option, it works perfectly.

Ok, so i just went ahead with the obvious choice, we have the kitchen display in our kitchen so we added a display in the waitress area to duplicate the kitchen display, basically. Now their orders appear there. Works fine now. Still don’t know why it stopped working properly when we tried to add the ability to print a waitress ticket, but adding the display is more cost effective anyway because it saves paper.

Ok now i’m truly dumbfounded. I removed the print option but i’m still hitting the same issue. When I add an order to the system using the mobile tablet, it creates a ticket but does not assign it to the table. What am I missing?

Something is wrong in your setup you changed something.

Its crazy im beating my head at this point, lol. I have it working fine on 2 android tablets. On 2 phones, it does not work correctly tho. I updated settings and pushed update on the screens. Even uninstalled samba mobile and cleared all cache. Why is it working on some devices and not others??? Side not, the devices its NOT working on are the ones I attempted to setup the option to print a slip for the servers. I have removed that option and it still does not work. The other devices never had that option and they work fine. I added a new device, connected it, and same problem. I haven’t changed any settings in Sambapos that would modify the way mobile client enters orders. I dont know why it is working properly on 2 devices, but not on others.

I just removed all the settings for mobile client and re entered them. Still the same. On 2 devices, it works, on the others, it does not work properly.

Try updating it on those 2?

Did that, it still continues to work fine on the 2 tablets (which are actually very cheap android tablets) and does not work on 2 mobile phones (both samsung Galaxy)

I have been messing with this for hours, I have noticed a few odd things. Still works fine on 2 tablets, on the 2 devices it is not working properly, sometimes it will create a ticket and ASSIGN IT A TABLE NUMBER but it wont show on the table selection screen that there is an order on that table. You can only see it if you go to the ticket screen and select that ticket. Sometimes (very rarely) it works as expected. then it goes right back to creating a ticket, submitting the ticket, showing it as a new order on the kitchen display, but not assigning it the table number. Very odd.

@QMcKay I wonder if QMX will work. I’ve been checking it out and I really like it, a lot. Nice work! I upgraded to Windows 10 Pro and SQL Server 2016 is now up and running. I think I’ll give it a shot. Looks like there is a trial mode for it, is that correct? If it works out I’d love to buy 3 or 4 licenses for it.

QMX questions need to be made on his QMX forum not here. He probably wont answer them here.