Hotel Rooms (Entity?)


#101

Once again a lot learnt about syntax and Variables (Remembering tomorrow the hard part). Finally went the route of setting a different variable for each Custom Data Field then copying that to the new room selected, Update the Room field in the booking Entity, Clear all the Old Room Field and finally Null set all the Variables ready for the next Transfer. Now need to tidy up the numerous unused Rules I have written and discarded and all the test messages.

And it works!
Finally think I am in a position to implement the POS as it now fits the business model.
Just set up the Printers, terminals, inventory etc etc. Spent far too long on the Hotel side but will be worth it.
Many thanks (probably not for the last time) @JTRTech.


#102

HI sir i am glad for you kind contribution in sambapos. For sometime now i have tried to implement a booking system with samba just as you have done but i have terribly failed. I know you have a lot of experience in that regards.Kindly share how you managed yo achieve this especially on adding the "GENERIC Questions


#103

Share what you have done and screenshots and will try and advise on your issue.


#104

ok JTR ,i will share once i get back in the office in course of the week sir


#105

hi sir,
Kindly let me how you managed to add multiple actions on a single rule.
On this case though
Generic Update Program setting-update Global


#106

kindly let me if this is the right procedure.
I have gone to the Actions and added the same action several times and also added the same action type several times .so i now have 1 action replicated severally on the same rule ,is it the right procedure though


#107

On the add action popup right click on the list and choose ‘show all’ it will then show actions already added to the rule.


#108

hi sir where is the pop up,tried to locate but cant find it


#109

i was able to get the pop up as you said jtr. I have some issue though while setting up the room entity grid.hope you will assist


#110

Hi kindly assist me on this issue.I am trying to set up my hotel rooms and i cant go beyond this point


#111

While tying to set up the room entity for the hotel as JTR has illustrated above, we are experiencing this error. How can we resolve?


#112

That’s not your screenshot?
This constraints are not an options, the field is hard coded to show on the rule instance of each action…!


#113

Because you should not make an action with a [:carried field] of a parameter/rule value, like the message says, just read it.
You have a field in your action which is the same as automation command name value for ACE rule.


#114


#115


these are my actions,i will appreciate if you can show me how the parameters are supposed to be set.


#116

Simple solution, make sure your [:xxxxx] carried field labels all have spaces rather than space less, look at you automation command action… Add spaces between each word and you’ll be golden.


#117

please excuse my naivety, JTR .I am trying to understand the whole set up slowly. I hope i will catch up with you guys,its my sincere wish.i will keep you posted with my progress and i am really grateful of your immense support


#118


#119

Hi JTRTech sorry for reviving an year old topic,but i really want to set up Room entity grid like you have illustrated in this tutorial. I am having issues with getting past the Ask question Action.
My ask question action is not passing the constraints to the rule.
Kindly see what am achieving hereby attached and let me know where my problem is?
capture9


#120

In your “Generic Ask Question” action.
In order to type a value inside the Rule you have to first parameterize it.

For example.
In Question box type [:TheQuestion]
In Buttons box type [:Button]

Do this for all the boxes you want to pass into the rule so you can type its value there.

Then in your Rule
Click Select Action and on the right hand side highlight Generic Ask Question and press “<–” to remove it.
Save it
Press Select Actions again and Select Generic Ask Question again and save it. You should now see the value boxes on the screen to use.