How to add a terminal to SambaPOS


#21

Ok that looks good can you show the error message your getting?

BTW on the new terminal change Terminal Name to something other than Server.

To do that go to Settings > terminals and create a new terminal then go back to Settings > Local Settings and select the new terminal for Terminal Name.


#22


#23

feeling ashamed to tell that it looks working now !!! please let me be sure in minute


#24

YOu may already know but dont be confused by Message Server saying its not connected that actually is different and has nothing to do with the Database.

This Explains message server.

http://forum.sambapos.com/t/message-server-tutorial/1042


#25

its definitely working…however, the issue will be there when i will disconnect wifi and connect the PCs through network switch


#26

Are they on the same network?

When you connect it to the switch via cable what is your error message? That could be a firewall issue or blocked port etc. Could be a number of things. If its working via wifi but not cabled network then its not a SQL Server issue or a SambaPOS issue it sounds like the switch or something hardware based.


#27

currently (when its working) they are on same wifi. however, there is no internet at my restaurant. so i netwrok PCs through network switch. they connect and can see/access each others files/folders


#28

Read through the common problems post I shared a few posts up. It likely has a fix that will work for you.

http://forum.sambapos.com/t/common-database-connection-issues-how-to-resolve-them/6500


#29

fine. let me read through that. however, please help on the other issue…convert CE to SQL. I did as per tutorial however, it gives error


#30

I cant really help if I dont know the error. Can you show that?


#31


#32

i tried on 3 different PCs…same error on all


#33

That is a very old tutorial and is not reliable. instead read this:

http://forum.sambapos.com/t/sql-express-2014-installation-bonus-how-to-convert-from-ce-to-sql-express/6956/2


#34

OK…i will try with this…and will let you know …thanks a lot


#35

Its little more details but its a better way to do it and does not rely on an outdated tool.


#36

Sure…will use this


#37

With the networking issue how did you open the firewall on the server?
Did you specify work and home networks on the rule?
Check that the wired network has not been set to public or unassigned as if there is no gateway or network type not selected this can happen and if your firewall rule is set to work/home only the firewall might be blocking when connected by wire.


#38

i used this and all went well…however, when i selected the newly created database and tried to create a ticket on migrated customer…system threw an error and closed. thats what happens whenever i try a ticket against a customer on newly created database. however, if i revert back to my database which was there before migration…it works OK…but it has no data as data is imported into the newly created database. name of my default data base is SAMBAPOS4 which works ok…name of database created for migrated data is Mydata3…this shows everything from the legaly system, however can process a ticket. screen shots attached below


#39


#40