How to stop printing two receipts

I’ve been working on a solution for a friends bar and almost ready to present to them. I just installed an Epson TM-T88IV thermal printer, configured receipts to print to it and have 1 copy configured to print. For some reason, it prints out 2 copies every time we print. I searched the forum first but can’t seem to figure out how to reduce this to 1 copy.

Thanks in advance

Are there two prints of the same template or different.
If the same you either have copies set to 2 in the execute print job action, the action or actions in your rule twice or have multiple rules with print job being triggered.

I hazard a guess your new to samba and you have two different templates - the second one being the kitchen printer copy as you set both ticket and kitchen printer to the epson printer?

Two identical copies. It’s a stock install of Samba, not made many changes regarding printing.

I checked the Action | Execute Bill Print Job, copies is blank. Have set to 1, restarted SambaPOS and still prints two identical copies.

Not using a kitchen printer. (fixed the typo)

Stock install defiantly doesnt print 2 identical copies so if you havn’t edited anything related then maybe check your printer/driver settings.

can you show your printjobs probably you have set 2times the same printjob somewhere

I confirmed the windows printer preferences is set to one copy, so it’s not the driver settings.

just tried print bill clone myself and it doesnt copy twice so probably your safe with that but okay i will try and find where your issue is.

so could you explain to me clearly what you want. what i understand is that you want 1TIcket to come out of your printer at the bar for yourself and 1 copy for the client so 2tickets total right? and right now you get 3tickets?

Just want ONE receipt to print.

Customer places order.
Bartender enters into POS.
Customer pays cash.
Bartender inputs cash amount and presses the cash button.
Register drawer opens and one receipt in total prints. (No need for 2 copies)

then just let copies be blank cause 1 copie =2 tickets (1 original and 1 copie ;))

EDIT: as pointed out to me 1copie means 1print :sweat_smile:[quote=“JTRTech, post:15, topic:14319, full:true”]
1 is not 2 with it meaning I copy it is 1 print… 2=2 prints not 3…

Changed to blank, saved and restarted Samba, placed an order, selected cash, two receipts still print.

try printing ticket normally(print button) if it then prints double it probably is because you set driver to 1copy [quote=“jot, post:7, topic:14319, full:true”]
I confirmed the windows printer preferences is set to one copy, so it’s not the driver settings.

if not then it probably is your automation command of payment where you have twice the excute print bill job

Pressed “Print Bill” and one copy comes out. So that’s helpful.
Settle the bill, and two copies come out. So it’s not the print drivers.

1 is not 2 with it meaning I copy it is 1 print… 2=2 prints not 3…

So your payment processed rule has a print bill action (pretty sure that’s not stock setup :stuck_out_tongue: )
Show your payment processed rule causing that open drawer and print.

You don’t have your kick code in your template do you?
Ie open drawer and print bill actions both printing bills.

ok, just chose Credit Card, and one receipt prints.
Chose Cash and two receipts print.

Getting closer

Think I might have got it with your kick code.
Show the payment processed rule for cash…

k :sweat_smile: will edit my comment just assumed cause my print bill is stock and has blank copies that 1copie meant 2tickets

No blank assumes default on 1 print, specifying 1 is same result.

1 Like