I cant open my samba

I did someting wrong… I tryed to delet averitng reference to samba so i could reintal like new and i think i idid something wrong bewcouse now I cant open sambe and it show this image…

Check the Connection String in this file:


It should look similar to the following, but adjust accordingly for your Data Source, User Id, Password, and Database:

<ConnectionString>Data Source=localhost\SQLEXPRESS; User Id=sa; Password=sambapos; Database=SAMBAPOS4;</ConnectionString>

Tnx I was cheking out what you told me and just realeazed that I deleted some wrong files so I just restored from my garbage deposit… tnx any way

I too am recieving that same error. Ive tried editing the connectionstring and reinstalling/deleting multiple times.

Any help please?

We need more information. Are you running SQL Express or LocalDB install? If you can not get your connection string to work then go to C:\ProgramData\SambaPOS\SambaPOS4\SambaSettings.txt delete SambaSettings.txt and restart and enter your correct connection string.

1 Like

I believe i am running localDB. I installed today(just to try the software) and realised that the samples were included in the DB. I tried uninstalling and reinstalling and am now reciving that error.

You probably installed as Local DB then uninstalled and reinstalled without Local DB so now its trying to find a db that doesnt exist. The only Sample data included is a very basic menu… you can just delete the menu. Just reinstall with LocalDB checked.