I think this is a strange behavior of HTML printer to cash drawer

Recently I’m moving from ESC/POS Emulated Printer to HTML. The cash drawer starts kicking everytime I press Print Bill. Do you know how to stop HTML printer from kicking the drawer everytime?

I would be useful to share the printing template.

Keep digging I found Regarding Print Cut issue in HTML Printer about need to create a secondary ESC/POS Emulated Printer very useful.

I think my issue was my printer in HTML mode always send drawer kick command everytime automatically.

My printer template is almost default, clean without any drawer command.

Html printer works just fine thousands of people use it so what he was saying is you must have a configuration issue but we need to know what it is. We can’t see your setup you have to show us.

It could be your printer drivers. What printer are you using?

I’m not so sure myself. Is it normal if I do test print from Windows’ Control Panel and the printer will kick the drawer? I really have no idea what I should show everyone about the issue. :frowning:

I’m using Citizen printers.

Thats probably a setting within your Windows Printer properties, if you cant find it there see if there is switch combination in the manual to turn it off.

1 Like

If you print in windows and it kicks drawer then it’s not a sambapos issue. Your issue is your printer drivers not html mode. Please check your printer settings and turn off any drawer kick option it may have.

Information like that is what we need to help you. Imagine we are behind a wall and can’t see you but we need to help you fix a problem.

1 Like

It seems there’s no switch for drawer in the manual. The printer sure has many switches.

Thank you! I will try here and there in the printer’s setting tomorrow and get back with more information.

Go to Printer Properties in Windows. Every printer driver will be a bit different but here is an example:


Set it to “No Cash Drawer” or similar, then you can control it with SambaPOS.

Some printer drivers have the setting in different places, like this one had on “Device Settings” tab, but it may be in “Advanced tab > Printing Defaults” or “Advanced tab > Printing Defaults > Advanced”, like below (note setting not there in screenshot, just showing you where it could be if you can’t find it).

Here is another example from an SNBC printer, you need to go to “Advanced tab > Printing Defaults > Operation tab” then check on all the 4 options to see where it is set.


Thank you so much, it should work correctly now!

1 Like