Installation Issue V5

Connection issue should solved before SambaPOS can add a database in databases.

in SQL Management tool its connecting

I think sambasetting.txt file is not creating properly, i tried deleting that but still same it does not have connection string in it:

<?xml version="1.0"?><SettingsObject xmlns:xsi="" xmlns:xsd=""><MessagingServerPort>8080</MessagingServerPort><ConnectionString /><StartMessagingClient>false</StartMessagingClient><DefaultHtmlReportHeader>
&lt;style type='text/css'&gt; 
  font-family: 'Consolas', monospace;
  font-size: 11px;

&lt;/style&gt;</DefaultHtmlReportHeader><CurrentLanguage>en</CurrentLanguage><OverrideLanguage>false</OverrideLanguage><OverrideWindowsRegionalSettings>false</OverrideWindowsRegionalSettings><DefaultRecordLimit>100</DefaultRecordLimit><WindowScale>0</WindowScale><NavigationScale>0</NavigationScale><FooterHeight>0</FooterHeight><UseBoldFonts>false</UseBoldFonts><UseDarkTheme>false</UseDarkTheme><ValidateExitButton>false</ValidateExitButton><AllowMultipleClients>false</AllowMultipleClients><AllowCustomNavigation>false</AllowCustomNavigation><AutoMigrate>true</AutoMigrate><TokenLifeTime /><DebugRules>false</DebugRules><EnableJsDebugging>false</EnableJsDebugging><CustomSettings /></SettingsObject>

It wont need connection string if its using localdb.

According to your logs its trying to connect but cant so it knows where and how to connect but it cant. You need to fix that connection issue first.

I have no idea what to do… tried alot and everything but nothing changes.
according to the post shared above i followed the steps but at step 5, dont see any database file…

Try this, uninstall SambaPOS delete the folder that has the settings.txt file. Find and remove SQL Server localdb. You can usualy see it in add/remove program files. Then reinstall sambapos and choose localdb 2014 or you can opt to install SQL Express 2014 instead and use a connection string. I highly recommend installing full SQL its easier to troubleshoot.

If you install full sql then uncheck the localdb install option. Download and install SQL Express 2014 and follow this tutorial to set it up:

This tutorial goes with the SQL Express one it solves most issues with SQL Express

1 Like

i did all but nothing changes…tried all possible error, i am able to connect in management studio with both windows and sql authentication but sambapos still does not connects with sql server

could you please show us the screen where the SQL connection has the actual connection data? and could you please show us sambapos settings.txt file, so we can see if there is any miss spelling?


So looks like you switched to SQL Express… but you did not set a connection string. You need a valid connection string for SQL Express. Yours might look like this:

Data Source=TAYYAB\SQLEXPRESS; Database=SambaPOS;

Try that.

I assumed your using windows authentication. If that doesnt work I can show you how to enable sa user and set that info in the string.


you where faster than me… this time…

you remember the comic “Speedy Gonzlez”?


1 Like

Hurray!!! Finally it connected. Thanks alot for all of your support.

No i have a live system working, and i want to copy that systems data and setting to newly installed SAMBA. What is the best way, i did restore & backup earlier but that copied license files too, i don’t want to copy license as this will be test machine. Also that machine runs localDB 11 and new machine runs sql express 2014

Use the built in SambaPOS backup module to create a backup of your database. Copy that to a removable disk then in your new test machine use the database backups module to load that database. First be sure these options are set as shown in the screenshot.

Make sure Manage addon licenses on backup and restore is not checked on main machine before you create the backup.

You will be able to run your test machine in trial mode using your database.

It gives following error

and somehow it already has license information from live machine (may be because i restored database earlier with the addon/license option enabled) how to fix it now?

You need to define a better place to store backups. Sambapos wont have permission to your users dir.

One second I will tell you what to do about license.

Can you go to SambaMarket and uninstall v5 license?

Open mssms and navigate to dbo.AddonLicenses is there an entry for V5PROLicense?

First issue resolved, backup restored.
I can go to SambaMarket but there is nothing installed not even license & yes there is V5PROLicense entry in ado.AddonLicenses

Should i remove the license key in database?

Yes remove that then restart.

Thanks issue Resolved.

I removed key and restarted but nothing changed. Then i click on install license in sambamarket and then uninstall and restarted. It worked. Thanks for support to all.

1 Like