Item modification Delay

Hi Everyone,

I have a strange problem. generally, sambapos runs very smoothly. adding items is quick and the system generally runs fast. reports can take some time but generally, it is fast.

the problem comes when selecting an item that has already been added to a bill. say we need to cancel/void or just add a modifier. This can really take a long time. you have to select the item and wait a good 5-10 seconds for the next modifier screen to show up. if you press twice thinking it hasn’t worked it then both presses will eventually register, putting you back to square one.

any ideas what could be causing this? thanks for your ideas

Something specific to order selected so couple of things to start;
Any order mapped automation commands with ‘complex’ header - ie report type expressions?
What kind of order tag setup do you have? If you have a product with no tag groups mapped is issue the same?

Hi thanks for such a quick responce,

I don’t think any complex headers as no real specific extra automation commands.

also no order tag groups, instead all items bring up the same free tag modifiyers which we write as we go slowly building a list. then periodically I will go through and reduce the number leaving only the common ones.

Maybe pre-defined order tag groups would actually help this?

I dont know, how bigger list you taking?
Would be helpful of you can post some related screenshots.

How many free tag modifiers do you have saved? I have seen something similar like this where staff did not use a system properly and had 500+ free tag modifiers and made selecting an order take over 30 seconds each time. This is possibly your issue?

Failing that, what spec of hardware are you using SambaPOS on? Specifically CPU and RAM?

I also had this happen with a physical harddrive going bad. IT eventually became unusable and I had to buy a new HD and load my backup on it.

Download CrystalDiskMark to see your read/write speeds.
I had an SSD go bad after 4 years of running my SQL server and the write speeds on my SSD were >1 MB/s. I bought a server-grade SSD on Amazon and it’s running fine for now.


Hi Guys thanks for the responses, hadn’t realised I had free tagging on and the staff were just free tagging instead of looking for the pre used modifications resulting in a couple thousand tags!! deleted the lot and removed record free tags and problem solved! :slight_smile:

1 Like

I dont bother keeping free tags for that exact reason, staff are lazy LOL

I feel quite embarrassed that I didn’t consider that before posting here! no option to multiple select for deleting either so it took me nearly 15 mins just to delete them :rofl:

I would have just deleted the tag and made a new one :wink: