Ive just upgraded and lost data


I just upgraded version 4 to the latest version and selected to install SQLCE. Now all my data has disappeared. Is there a way to go backwards and retrieve the data and then import it into SQLCE or even just get the data back?



IF you were using SQLEXPRESS. CE is limited functionality compared to SQLEXPRESS. What were you using before you tried this?

I highly recommend you NOT use CE.

Your data disappeared because you originally set it up to run on a method other than CE. So it has now created a new CE file to run from. You simply just need to connect it to your previous data. If we knew what you were using before it would help.

1 Like

The previous data was whatever the default setup is without using SQLCE. Im not sure what type of database that is.

I am not too familiar with the structure of the LocalSQL install. But I will recommend you follow this tutorial (Much more robust setup):

what is the default database as I need to restore my data

Default is SQL Server LocalDB

Uninstall SQL Server CE and it should work fine.

I have uninstalled and reinstalled and on installation selected LocalDb. Now I get the error message on loading:
Cannot open database “SambaPOS4” requested by the login
the login failed.

I just need to get back to where I was yesterday with my menus and entities all showing!

I really appreciate your help.

OK, Ive uninstalled Express. Now it loads but the data is missing. Please can you tell me how to get my old data?


I think what I am looking for is a copy of my original SambaPOS4.txt file that was in My Documents. Does the software overwrite this without warning?


  • Uninstall SQLCE.(not express, SQLCE)
  • Leave connection string blank.

I can find and mdf and an ldf file. These may or may not be my data as I thought my data was in a txt file. Anyway, Ive decided to reload all the products, entities and menus and have install SQL Server 2014 Express and toolkit.
What is the string to connect to sqlserver 2014?

@Jesse @enme
We are opening in 3 hours for a busy night. Please can you help me retrieve my data. I have teamviewer if you would like to log in to the laptop?

Help! Ive installed express 2012, express 2014. Ive tried a new installation. I don’t want to run without a database.
I have a 7MB .mdf file but cannot seem to attach that. Any help would be gratefully received.


i can help you. If your original data was in a txt file then that means you were in test mode and you never really had any data. I do not know what mode you were using SambaPOS in originally and you seem to be confused on how you were running it as well.

I can help you with team viewer if you wish.

You only need 2014 you do not need both.

PM me if you want me to assist you with teamviewer.

ok thats great , let me set up team viewer. I can chat on this while you log in to the PC laptop

Ok I am fixing a bottle for my daughter I will check for your PM in just few minutes.