Kitchen/Bar Monitor not updating


#1

In our restaurant we have 1 server, 3 terminals for order taking, and 2 computers for kitchen and bar display (one located in the kitchen, and the other one at the bar).
Terminal 1 does automaticly update orders sent to our kitchen and bar display, no issues with that one.
However, Terminal 2 only updates orders sent to kitchen display, while orders sent to the bar, show up only after we log off, then log on back again.
Last, but not least, Terminal 3 orders dont update either in kitchen or bar display, same issue as with Terminal 2: they show up only after we log off, then log on back again.

I have been doing some research al over this forum, but havent found a solution for over a year…
I cheked Message Server, which sems to be working, since I get “Connected” at every PC.
I went to “services” at my server, and restarted Samba Message Server.
I verified that no other computer was runing Message Server.
All my terminals have same configuration in Message Server Name & Message Port.

Can anyone help me? Is anybody else having this same issue?


#2

try using the servers IP address instead. Make sure windows firewall is turned off. Check your entity screen settings make sure auto update is on in the widget settings if it is a custom screen. Make sure there are no conflicts with that port… maybe try port 9000 instead.

Check and make sure there is not any custom automation that might be interfering with the refresh. You can test that by deleting the mapping from rules you suspect one by one.


#3

Thank you for such a fast response. How ever still not working.
I used http as you recomended, and changed to port 9000, turned off Windows Firewall… No luck yet! :thinking:

Here is a screenshoot of how bar monitor updates from Terminal 1.

Next, Im uploading properties. I have tried both, autorefresh, and refresh interval… no luck…

Im also uploading some screen captures for automation and rules… as far as custom automation, I havent changed those, since im not an advanced user, except for a customer monitor setup, but Im having this non updating issue ever since I instaled Samba.

If you would be kind to give it a look and maybe point me in some direction, I would apreciate it so, SO much.


#4

Run Message Server Service Tool on the Server and ensure the port is set to 9000+ (be sure to include the + symbol.)

C:\Program Files (x86)\SambaPOS5\Samba.MessagingServerServiceTool.exe

The Actions involved in the Automation look fine. No need to see any more of those. The Rules however are impossible to tell, since you have not expanded the Actions inside the Rules. Please expand them and post new screenshots of the Rules.


Show your Print Job KD Execute Print Job GUI - ANY, specifically the Mappings.

Show the Printer settings for the Task Printers, specifically the “Settings” link that shows the Task Type being used. Also be sure there is a DOT for the Printer Share Name on your Task Printers.


#5

Thank you for responding me.
Sorry I couldn’t reply before, had so much work, and couldnt mess with the system on work days.
Im posting some screenshots to show settings. By the way, there is a Dot for printer name on Task Printers.

Also, do you think there any chances ports are causing this problem?
I runned Message Server Service Tool and as you can see, its runing port 9000+, however on Samba Message it shows 8080 port runing, and when I try to stop it, Im unable to do so… Got any idea why this is going on…?


#6

What is this? It should not be running. There should not be an Apple icon in your Tray area either.

image

There should be 1 instance of the Messaging Service running, and that should be on the Server ONLY. No other Terminals should be running the Messaging Service… they connect to the Message Server Service on the Server machine.

Do NOT run this:

C:\Program Files (x86)\SambaPOS5\Samba.MessagingServer.exe

Only run this to set the Port, and install the Service on the Server ONLY, then never run it again:

C:\Program Files (x86)\SambaPOS5\Samba.MessagingServerServiceTool.exe


According to your screenshots, the Messaging Server Service is running on port 9000. All your Terminals should use port 9000, not port 8080. Also, your Message Server Name should include the http:// prefix. So all Terminals, including the Server, should look like this:


#7

Install the MSTC DB Tools import File. It is the easiest way to check your Messaging Service…


#8

Hello QMcKay!
Thanks again for your response. I imported the file you sent me, and as soon as I type any text in the MSTC, it shows up on all my terminals, as well, as response from all of them.

Well, as far as my problem goes, today I went a little further and even installed a fresh windows copy in a pretty decent PC, wich i’m now using as our “new server”, since I couldnt shut down port 8080 in my old server, yet, im still having this same problem… Orders not updating…

Im starting to feel some kind of disapointed on my self (LOL), for not beeing able to setup my system like most guys here do.

Is there any other point or recomendation you could kindly guide me to try or check?


#9

Great! This means your Messaging Service is working properly, and we can now forget about it.


For the Task Editor Widget, make sure Auto Refresh is checked and the Auto Refresh Interval is set to 0.

Show screenshots for:

  • Custom Product Tag Captions ( Manage > Settings > Program Settings > General Settings )

  • Product Tag Editor, specifically the productType field/column ( Manage > Products > Product Tag Editor )


#10

QMcKay, thanks for responding. Im sorry I couldnt reply before, had some issues; and had to take care of them so, I was away form my system.
Anyway, I took some screenshots for you to look at. I even checked my LAN devices, and they all seem to be working fine. They are able to communicate eachother… I’ve done some research on the forum, hoping to find a solution from another samba user, but no luck yet…