Kitchen printer Epson TM 220 font

In the windows printer preferences of the 220 I chose font size 22 and they like it. Makes it easier to read.

However, it doesn’t print correct in samba.

How can I fix that?

Your character count is wrong.
Why Windows printer settings?

I tried some html things inside the printer template and it didnt work.

Maybe its me. Got an example?

Show a screenshot of your printer setup

And paste your entire ticket template within a code block...

That only works if you set printer type to HTML printer. in Settings > Printing > Printers

I have messed around with it so much that I think my formatting is all out of whack. It started printing and wrapping the text like in the photo up above in earlier posts, so I messed with it…

Kitchen Template (want it large so they can see it)

<L00>********** KITCHEN **********
<L00>Server: {USER NAME}
<L00>Ticket #{TICKET NO}
<span style="font-size:15px;text-align:left">
<L00>Table:{ENTITY NAME:Table}

– Default format for orders

<J00>- {QUANTITY} {NAME}|Void

– Format for order tags


The wrapping text is character count in printer settings.

Not large

Show your printer setting. Did you set it to HTML printer?

You want to see windows print settings?

No I do not care about windows settings they are irrelevant. I mean in sambapos.


Ok so you did not set it to HTML printer like I suggested. See where it says Printer Type… make that HTML printer.

Sorry I am learning fast, but such a n00b at this software.

Ok now we are getting somewhere.

It’s not correct but getting there.

Now adjust your Line Character Count until it fits correctly.

I set it to 10 messing around and its still way off the page.

Well your top part that says kitchen is not right because you manually set those astrisks. But it looks like you need to increase it to like 43 or 44

BTW we are not talking about Line Count keep that at 0 I specifically mean Line Character Count

If anyone and mess something up I sure can. I like the font size at 20 but the top is garbage. It’s wrapping the dashes too. I set it the line character count to 44 and line count is 0.

So you need to reduce Character Count then. Looks like your using 58mm paper. Maybe try 30s on Char Count.