Licence Drop on Single Terminal

Ok, so since updating from 1.62 to 2.18 I have had licence drop several times on a single terminal.
Its only one terminal out of the several there.
When it happened previously I found samba market logged out but licence still installed etc.
No one has admin access other then myself and this includes access to the market module.
Today they had it again but on top of the unregistered trial on header and popups they also got a popup asking for contact details.
The system has gone almost 3 years without any licence issues and now since updating have had 3 drops on this terminal :-/

This was the message received today;

This time rather than just logging back in and restarting I uninstalled and reinstalled licence module too. See ho long that lasts.

Any suggestions?

Is there any automation for running built in backups with thee database backup tool?

Backup on work period end, has been like that since day 1.

Sometimes backup do this.
Can you stop that for controlling.

I can disable backup for sure. Have to question though the complacency of accepting that a built in function of Samba is a cause for licence to get dropped.
And then solution is to use external function such a direct SQL backup.
This was half the reason I held back on updating the hotel since initial install where it was running 5.1.62 I think or maybe even .58 as had found this version to more stable for licences, all 3 hotels in group have run for between 2 and 3 years without issue other than where terminals were added which I can understand reactivation may be required for that scenario.
This is the main hotel, the other two continue on the older version WITH auto backup on work period close without issue.
I needed to update for some new functions/features to go with my tablet setup and low and behold within a week I start having regular licence issues after updating.
The hotel is my day job so they are very understanding as they get great deal for complex custom setup, if this was a new client it would be pretty embarrassing.

Have you already tried to clear key, then logout and login on SambaPOS, activate the license again?

You may find in 5.2.18 and other recent versions, when you login first activate button won’t do anything but if you close SambaPOS and reopen, go to Samba Market and you will still be logged in, click Activate and it will work. I have to do like this on pretty much every new install I do.

The trick to logout of Samba Market is no longer needed in recent versions. You are best to keep it logged in.

I haven’t had a license go back to trial for some time now on anyone on recent versions, so it is definitely more stable.

With regard to backup causing it, every setup I do has auto backup on work period end, never caused issue with license.

I cleared key, reinstalled licence module and re-logged in on all terminals following the update and tablet addition.
Didnt this time, just loggin back in and restarting reactivated.
Just seems very vague as to what is actually meant to be done other than our best guesses.

I know if you add more terminals and connect them you usually have to clear key and reactivate. You only need to do it on one terminal though, I usually do on the main “server” one.

Never had to do that.

I just did it as a cover all bases, but thats what I mean about vagueness of it, sometimes this works, sometimes that works, other time something else. And then some other fact makes it drop and it starts over again. LOL

I had a similar problem. The only thing I did different that day was put the server machine into “Training Mode”. (Might be the backup issue @VehbiEmiroglu mentioned.) Of course that was when we first started using SambaPOS and we hit the 500 ticket trial limit.

I don’t remember installing licenses on the terminals (I may have, just don’t remember). But I had to (re)install licenses on all the machines, including the server.

I would understand how training mode might cause a dropout (although it really shouldn’t) since it is changing the active db to a second unlicensed db as licence is per DB.

Its just annoyed me that go so long without issue and not updating in fear of this exact situation and my fears seemed justified. Will persevere finding the exact sequence to prevent.

Perhaps a failed backup? Just looking at something else and notice last nights backup shows a reasonable drop in filesize. Seems odd for a consistent increase every time before.

Also gap of backups there. Odd

I dont know why but I honestly feel the older version of V5 worked a lot better than the newer versions. It had less crashes and less license issues as well. I’ve lost count of the amount of times the license would suddenly drop sometimes for no other reason than a wifi drop out.

I origionally put it down to qty of transactions but since updating have also had to remove the entity screen state formatting report expressions as well as my automation command headers that counted hold and temp tabs tickets since updating as it got allow worse and sometimes even froze up if they were impatient and kept tapping.

I’ve had good success with 5.2.18 it runs nearly flawlessly. Some of the older ones didn’t.

1 Like

I had a similar issue but I would just turn off SambaPOS on the server and turn it back on again and all the pop ups would disappear.

My issue was hourly backups using built in automation. Since then @markjw pointed out to a SQL backup scheduler and its flawless since I implemented it to every client I have.


I looked to code but seems everthing fine.
It mays be occured when SambaPOS didnt write the backup to disk.
Can you recheck again.