License not found on switching from Mobile Client v2 to SambaPOS MC3

We just installed the new SambaPOS MC3 app, and on the same phone, had v2 installed as well. V2 worked fine with the server pc. But MC3 says license not found. We have one app license, and to make MC3 work, I removed the v2 app from the phone. But still the same message.

Your help is appreciated!!!

Did you update to sambapos 5.5? You must update to 5.5 and run the licensing app first

i have the same issues not solved

i do the updates

Did you restart the message server?

yes i do the restart for msg srv

I had a similar issue after the upgrade and @mehmet gave me a solution which worked for me.

  1. Make a database backup.
  2. Open the SSMS and go to your SambaPOS database.
  3. Delete all the lines in the AddonLicense table
  4. Run licensing again
    Now try to login with your mobile client. Should be solved.

Hello Stanko

I’m still not getting my licenses to work on MCv3, could you with a little more detail tell me what tables to delete in AddonLicense table?
Thank you
2022-07-06 14_31_13-Microsoft SQL Server Management Studio (Administrator)

Hello @stephanhenning,

In case you apply below steps the problem should be resolved;

  • Re-download SambaPOS 5.5.0 from and install over the existing one.

  • Click on Clear Licenses button from the Samba Market part of SambaPOS and restart the SambaPOS completely (exit even from PIN entering screen).

  • Restart SambaPOS Message Server.

1 Like

Thank you, this has helped me connect to the database.

Hello … I have the same iLicense not found ssue now. I did the clear licenses and restarted SambaPOS as well as the message server. I checked on the DB and both mobile client licensees are removed after then clear licenses and added after the restart of the POS. I acquired the Licenses today. Any idea? Server is 5.5.4 and client 3.0.6.