Login screen issue - having to touch the screen first to allow a mag card to swipe a login on first load


#1

@emre ive noticed a small issue when first logging into samba, when it loads the login screen i cannot swipe a mag card to login as it doesnt seem that the focus is on the pin entry area. that area is highlighted with an orange box but when swiping nothing works, i first have to touch the screen anywhere which then seems to set the focus and allows me to swipe to login

so on first login i have to:
load samba
touch anywhere on the screen (touchscreen monitor)
then swipe to login


#2

I’ve had clients complain about this also.


#3

Does it receives keyboard input when that happens?


#4

@markjw are you encountering it on latest version? I think I fixed it 2 or 3 versions before.


#5

No, you need to click/touch the “enter PIN” field.

I saw it last on 5.2.18 when I was doing an on-site install. However I haven’t really noticed it much, just thought I’d mentioned as I had seen the issue before. Possibly other times was 5.2.14.


#6

There was an issue regarding not focusing the PIN area so it does not have the orange focus indicator border and not captures keyboard keys. I also reproduced it and released an update to ensure it focuses properly. I didn’t noticed a related issue after that update.

Now the issue is PIN area gets focuses fine (appears with orange border) but it still does not receive keys. In windows there is always a single active window that receives the keyboard input. So that probably means SambaPOS main window is not the active window and some other active window receives the keyboard input. It is hard to tell what can it be but I’ll add some more code to force SambaPOS window becomes the active window.


#7

No it doesn’t receive keyboard input either, you just have to touch anywhere on the screen first and then it will accept keyboard and mag card etc


#8

I’ve just turned on pc to test again and I don’t have anything else open just samba and it still doesn’t work, still need to touch the screen first even when samba is the only application open


#9

Is it doing it on every new start?


#10

Yes on every new start it does it


#11

Well it is weird something clearly steals focus from SambaPOS. Are you running a keylogger or something like that?

For next update I added a focus capturing feature that works on Windows API level. Now it should work fine. On the video you can see how SambaPOS captures focus even while I’m typing in notepad.


#12

no im not running anything, literally turn on the pc, click samba icon to load then have to press the screen to allow to type/swipe

What i have noticed is ive just turned on the rule de bugger and reopened samba and when rule de bugger is active it works fine (ive only tested that once though)


#13

I remember a related change with rule debugger recently? @emre I think you changed something with rule debugger I remember an issue with someone’s action constraints not working but they did work with rule debugger on and you said you changed something. Maybe that affected this?


#14

Are you encountering the same issue?


#15

I haven’t noticed honestly.


#16

I was thinking it is something related specific to Rick’s system. Can you type PIN code when you first start SambaPOS?


#17

I’ll test when I get back im out of town shopping for supplies ATM.


#18

Ive just done some testing and if start samba with double click on desktop only, but if click a third time on desktop or samba shortcut you get samba with orange border on enter pin but keyboard doesnt input to field.

When you ‘grab’ focus if it very first thing before loading screen loads? It seems like the focus maybe is being requested imediatly on aplication start before any window opens so any additional click then takes focus back off samba.


#19

Just been doing some tests and typing PIN code worked straight away. i then shut down and and restarted and tried mag card swipe and it didnt work. i shut down again and tried scanning a barcode and that didnt work.

i shut down again and tried entering PIN via keyboard and it worked

i then repeatedly shut down a restarted and mag card swipe starting working first time without the need to touch the screen first. It seems if you shut down and restart instantly mag card work, but when the pos is shutdown for a long period when you then restart you need to touch screen first for mag card swipe to work

@markjw said hes had clients complain about the same issue too so it isnt just restricted to my system


#20

So it’s random whatever it is.