Microsoft SQL Server Installation Problem

As you can see neither services are running. Your v4 nor your v5 instance is running.

I try to right click them to start, but it doesn’t give me an option to start the service.

Something is wrong it must be missing a dependency or something. Completely uninstall it including your v4 instance, BACKUP FIRST, then reinstall just the v5 instance from scratch and see if that helps.

Just want to make sure… you had SQL Server Agent selected… the service you need to ensure is running is the SQL Server (SAMBAPOS5) service.

So I have to go to

  1. Control Panel -> Programs and Features
  2. Click on Microsoft SQL Server 2014 (64-bit)
  3. Click “Remove”
  4. Select and uninstall both “sambapos4” and “sambapos5”

I get this error when I manually try to start SQL Server Agent (SAMBAPOS5)

Ok, hold on here. You do not need to run 2 Instances, and this might be the root of the issue you’re having.

You can have multiple databases in a single instance. This is why I do not suggest renaming the instance from SQLEXPRESS to SAMBAPOS at all. It confuses people, because many do not understand that the Instance is not the same thing as the Database.

You only need 1 Instance. Look here - I have a single instance called SQLEXPRESS, with 9 Databases…

This Tutorial shows how you can backup your V4 Database, create a V5 Database, and import the V4 data into the V5 Database, all within SambaPOS using the built-in Database Backup Module…


Great point QMcKay you said what I failed too. I recommended only using one instance but failed to mention not to install the other instance. You should uninstall the entire thing and reinstall with a single instance get it working and then follow the tutorial Q mentioned above.

The problem is when I start up SambaPOS 5, it looks for a “sambapos5” SQL instance right on boot up. But I don’t have a “sambapos5” instance running. I tried uninstalling SambaPOS 5 and looking for registry keys to delete, but I can’t make it stop looking for the “sambapos5” instance.

Even before SambaPOS 5 came out, I had only ONE SQL server, “sambapos4” and it would still give me the same problems.

That is not a valid connection string.
Shoudl look allong the lines of Data Source=SERVER\INSTANCE; Database=DATABASE with User Id and Password is using SQL Auth rather than windows
Server = Computer Name (if local can use localhost)
Instance = looking at your screenshots either SAMBAPOS4 or SAMBAPOS5
Database = well whatever your database is called
Will find example/tutorial…

1 Like

Did you successfully install SQL Express yet? If so, what is the Instance Name?

In SambaPOS, set your connection to use this for a start:


localhost refers to your computer. This could also be or YourComputerName or the actual IP Address of your computer. For simplicity, on your Server, you should be able to use just localhost

So how do I edit the connection string? I can’t even boot up SambaPOS 5. It won’t let me get past that error message.

just type it into the box that appears and restart samba

Ok so I typed into the box:
Data Source=localhost\sambapos5; Database=sambapos5

I didn’t put a username/pass because I used Windows authentication and now SambaPOS 5 is stuck on the blue loading screen.

It should display an error message. Use Alt + Tab key configuration to see if any error message displayed behind other windows.

1 Like

Yes I just saw that error message. I started SambaPOS 5 again and put “Data Source=localhost\sambapos5; Database=sambapos5” into the text field, but I don’t think it’s going to work.

I think I still need to fix the SQL server installation.

edit: I am currently uninstalling the SQL servers and will name them the default “SQLEXPRESS” name.

Default database name for V5 is already SambaPOS5 so you don’t need Database Definition.

To ensure if you can successfully connect sql server or not please review documentation @JTRTech suggested. I’m pasting link here once more.

You can enter an empty space character in error dialog to force sambapos connecting to local sql database instance.

1 Like

Hmm I just found this from googling. Apparantly, you can’t install an SQL server over an RDP connection, which is what I have been doing the past few times. I’ll have to go over and install it locally later tonight. Then I should be able to connect SambaPOS 5 to the correct SQL server.

LOL, I came across that topic as well when searching. I just assumed you were local to the machine, so I didn’t bother mentioning it.

Yes, Microsoft states that installation will fail using RDP. You could use Teamviewer instead.

  • SQL Server Setup will block installations on read-only, mapped, or compressed drives.
  • The installation of SQL Server 2014 fails if you launch the setup through Terminal Services Client. Launching SQL Server Setup through Terminal Services Client is not supported.

Terminal Services Client is the same thing as RDP (Remote Desktop Protocol).

From this document:

Hardware and Software Requirements for Installing SQL Server 2014

1 Like

How do I make SambaPOS 5 not look for an SQL server on boot up?

Why would you want to do that? Can you explain the need we may be able to offer alternative that solves your real problem.

I tried to install the SQL server locally but it still did not fix the problem.

Edit: now when I try to run SambaPOS 4, I get an error that says "The database file may be corrupted. Run the repair utility to check the database file. *